View Issue Details

IDProjectCategoryView StatusLast Update
0016483MediaMonkey 5Track Browserpublic2020-04-13 09:02
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016483: Folders node is confusing to new users
DescriptionUnless the users read MM documentation, the Folders node can be quite confusing because:
a) it isn't up to date with changes the user has made to the database
b) changes made in this node don't appear in the database (unless the file monitor is enabled)

To improve this situation, it was decided to:
1) Add a Toast message to help users understand the functionality:
"The Folders node only displays/edits metadata in file tags. To view/edit metadata that's in the database, use the _library 'Location' node_."

Note:
a) Clicking "Library 'Location' node" switches to the equivalent node in Entire Library > Location
b) closing the toast message should prevent it from popping up again
c) There should be a mechanism in Tools > Options > Confirmations to '[ ] Re-enable disabled warning messages'
(we might want to even get rid of all the options there and just have a single option to reset all such confirmation dialogs / toasts)

2) Possibly change the default behavior of Folders so that tag changes made there are automatically applied to the library. As discussed, this is less critical once we change the default MM5 behavior to Monitor scanned folders, but such a change might be valuable nonetheless since it's probably expected behavior even if the file monitor is disabled.

If we implement implement this, the toast should instead be:
"The Folders node only displays metadata stored to file tags. To view metadata that's in the database, use the _library 'Location' nodes_."

TagsNo tags attached.
Fixed in build2241

Relationships

related to 0016482 closedLudek Tag editing under Folders node is broken (for files already in the library) 

Activities

Ludek

2020-04-02 16:48

developer   ~0057464

Last edited: 2020-04-02 19:58

View 2 revisions

1a/1b) implemented in 2239

1c) I would leave it as is for at least for 5.0
I think it is still useful to temporarily enable just "Scan results" dialog etc. -- without enabling all confirmations at once.
And this toast message is rather a first time informative mesage (that does not need re-enabling)

rusty

2020-04-07 22:37

administrator   ~0057535

Verified 1a) however, the toast should only appear when the user enters a Folder node from a different Root node. i.e. if the user is browsing from Folder A to child of Folder A to child of child of folder A, the Toast message shouldn't pop up each time!

Also, it might be useful to display this as a tooltip for the Folder node.

1b) Not yet verified

Ludek

2020-04-08 21:31

developer   ~0057567

Last edited: 2020-04-08 21:32

View 2 revisions

1a) ok, fixed in 2241 + added also as a tooptip for 'Folders' node

michal

2020-04-11 14:18

developer   ~0057579

Reopened, the fix caused, that files are not shown at all under Folders node now.

Ludek

2020-04-13 09:02

developer   ~0057583

Fixed in 2241 + prolonged the timeout to 10 seconds as some users (like Macarena from IFY-813-43824 ) indicated that 5 seconds is too short for reading whole the text.