View Issue Details

IDProjectCategoryView StatusLast Update
0018075MediaMonkey 5Hotkeyspublic2021-07-01 21:28
ReporterLudek Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.1 
Summary0018075: Renaming folder can result in tracks rating
DescriptionAs reported here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=99420 (and [Ticket # 1983])

Go to Folders node, select a subfolder and right-click it > Rename
Select 'o' and type Alt+162 to change it to 'รณ'

Tracks in the folder changes rating into 2 stars!

This issue seems to be caused by a conflict with default hotkeys for
Alt+1 : Rating selected files(s): Rate 1 Stars
Alt+6 : Rating selected files(s): Rate 0.5 Star down
Alt+2 : Rating selected files(s): Rate 2 Stars

--------------
Another issue is that the rating is changed only within the file tag (and not in the database). This is caused by the fact that the 'Folders' node behaves like the 'My Computer' node in MM4 and read/writes the metadata only from the file tag. While Music > Location subnodes writes/reads the info from the user database too. Sounds like a bug to me (although I believe that there were already some discussions that this isn't a bug). To be clarified, but I believe that once the edited track is part of the DB already then the changes should be propagated into DB too ?

EDIT: Seeing that this has been already tracked as item 2) in 0016483 -- so re-opening there for the item 2)
TagsNo tags attached.
Fixed in build2420

Relationships

related to 0016483 resolvedLudek Folders node is confusing to new users 
related to 0014964 closedLudek Hotkeys are not working, when focus is in edit controls 

Activities

peke

2021-06-28 21:52

developer   ~0064093

Inline Edit should trigger ignore on some (or all) internal MM Shortcuts.

Ludek

2021-06-29 12:56

developer   ~0064104

Last edited: 2021-06-29 12:57

View 2 revisions

Fixed in 5.0.2.2500

Is low risk, so could be potentially merged to 5.0.1 (in case of a need for RC-5)

Ludek

2021-06-30 13:57

developer   ~0064120

Merged to 5.0.1.2420

lowlander

2021-07-01 21:28

developer   ~0064141

Verified on 2420