View Issue Details

IDProjectCategoryView StatusLast Update
0016429MediaMonkey 5Playlist / Searchpublic2020-03-25 11:39
Reporterpeke 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version5.0.1Fixed in Version5.0 
Summary0016429: Search: Advanced Search/Filter UI Tweaks
DescriptionAdvanced Search/Filter can observe strange behavior
1. Edit Value field overlaps [-]
2. If Criteria uses Equals then there is no Type cursor in Value field and if you type AB (for ABBA) Drop down position to B instead of AB
3. In some cases Filter/Search is executed too early while user is still defining parameters, which leads to not needed use of Resources and UI refreshes. (Move to new bug if not related to this one)
4. As soon as you select Equals criteria dropdown is shown, I would rather open it as soon as User type in Value field
5. For Large Libraries it could be useful to Filter dropdown based on User Type (eg. Artist contains Typing value)
Steps To Reproduce4) Steps to see what is desired behavior on Gmail:
1. Open https://mail.google.com/ in browser
2. Click Compose New mail
3. Click on TO: Field
4. Type P and you will get dropdown lists of emails starting with P (Filtered as proposed in point 5.)
5. Select one (MM have multi checkboxes)
6. Type further you fill next email and repeating that it adds more equal emails to TO Field
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=96066
TagsNo tags attached.
Fixed in build2233

Relationships

related to 0016450 newLudek Filters & AutoPlaylists attribute chooser: filter rather than scroll to the attribute 

Activities

Ludek

2020-03-10 13:04

developer   ~0057135

3) Barry was rather objecting here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=96066
that the filter/tracklist isn't refreshed once the dropdown is closed, which looks like bug.

Ludek

2020-03-11 15:04

developer   ~0057146

Fixed the original problem reported by Barry + fixed the overlaping issue (item 1)

I don't quite understand the other items reported by Peke, so Peke should either elaborate (better explain) or close.

peke

2020-03-11 17:31

developer   ~0057150

Ok, I'll create Video files about issues, but most likely will create Separate bug for 5.0.1/5.1 as they are not essential features but targeted to improve usability.

rusty

2020-03-12 17:44

administrator   ~0057177

Re-resolving--otherwise the fixes will not get tested. It can be re-opened after the fixes have been verified.

rusty

2020-03-13 22:09

administrator   ~0057191

Tested 2232.
1. Verified
3. The view is updated, however, a consequence of the fix is that modifying a rating no longer works.:
https://www.screencast.com/t/6Ml2DQQ4
2. Peke is saying that for large libraries, typing to scroll to a filter attribute only recognizes the _last_ typed letter and it should recognize all typed letters. e.g.
For Artist = ______v , it would take very long to scroll to 'The Rolling Stones' so the user would try typing 'roll'
-->Artists beginning with 'L' appear (because MM only scrolls to the last typed letter rather than all of the characters)!

4/5. I'd leave as is

Ludek

2020-03-14 19:49

developer   ~0057196

Last edited: 2020-03-16 14:10

View 2 revisions

Items 2/3 fixed in 2233

peke

2020-03-20 22:50

developer   ~0057262

3) Verified 2233 looks like fixed can't replicate anymore

peke

2020-03-20 23:12

developer   ~0057263

Last edited: 2020-03-20 23:38

View 2 revisions

2) I still observe same behavior as in my video supplied at ~57154 (00:15) where I do not know what I am typing which is seen when you have Contains criteria not equal and using Rusty example from 0016429:0057191 Typing "Roll" Do not move drop down to "Roll Deep" Pic Attached

re 5) Typing "Roll" should filter Artists + Starts With (Best would be Contains) + Typing chars (delayed 300-500ms) eg. as seen in attached picture Filtered Artists would be from "Roll Deep" -> "Rollo Goes Mytsic"

re 4) The behavior I am proposing in this point to same behavior that Gmail is using when you are filling TO: field eg. While Typing you get dropdown list of known emails from Address book (our case Artists) that you can select and it moves cursor so that you can easily type next or open full dropdown list. This behavior explains why I added 5) to get filtered results. I have 21k+ of artists and I Only have 200k+ of tracks.

peke

2020-03-20 23:12

developer  

bug16429_2.jpg (104,150 bytes)
bug16429_2.jpg (104,150 bytes)

peke

2020-03-20 23:21

developer   ~0057264

6) This behavior from Point 5. can be also applied if Criteria "Contains" is used to show user quick dropdown and allow to do quick correction for better results eg. Typing "Roll" will show dropdown with artists "Roll Deep" -> "Rollo Goes Mytsic" so user can easily just add "i" to further narrow listing and evade complex rendering of full search query.

rusty

2020-03-24 16:55

administrator   ~0057317

Re-resolving this since the bugs have actually been fixed:

2) From my perspective, the current behaviour is fine. It works exactly as searching for the tree did in MM4. Though i do think that this could be added as a future improvement as part of the filtering you're proposing.

4) Filtering like gmail sounds like a good idea for a future feature.

5) Filtering for all content rather than just 'starts' with would be useful as part of 4) in the future.

6) Also possible, but not critical for a future enhancement.

I've opened a new bug 0016450 to track the suggested enhancements.

peke

2020-03-25 11:39

developer   ~0057337

Verified 2234

Agreed, bug was expanded to different aspects of issue. Further issues are noted in new bug. Closing