View Issue Details

IDProjectCategoryView StatusLast Update
0017646MediaMonkey 5Playlists (Auto) / Search / Filterspublic2021-03-23 23:39
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017646: Field equals X - attribute selection/editing issues
DescriptionWhen the user tries to choose/edit multiple X attributes for 'Field . equals . X', there are several issues:

1) Switching between criteria often results in attributes from a different criteria being deleted. e.g.
1 edit attributes for Genre . equals . genre1; genre2; etc.
2 Switch to Type . equals . music
--> the list of Genres for the first criterion is lost

2) Scrolling and selecting an item in an attribute list will often result in the list jumping to the previously selected item

3) Deleting attributes from a list of attributes is onerous as it requires the user to scroll through the entire attribute list to deselect
- It should be possible to delete items from the text box (as it is when using F2 to edit multi-attributes)
- It might be useful to show selected attributes at the top of the list (this is probably an approach that shouldn't be implemented piecemeal, but rather globally across the product)

The first two items are best viewed in the video below:
https://www.screencast.com/t/Zv39tvTw61
TagsNo tags attached.
Fixed in build2324

Relationships

related to 0016429 closedrusty Search: Advanced Search/Filter UI Tweaks 
related to 0015493 closedmichal In-place editing: multiple attribute handling auto-completes the wrong attribute 

Activities

rusty

2021-03-11 06:25

administrator   ~0062375

Tested this for some time in 2322 and can get both 1) and 2) to occur, but I cannot determine repro steps to get them to occur consistently.

rusty

2021-03-11 19:15

administrator   ~0062391

Last edited: 2021-03-11 19:19

View 3 revisions

Re. issue 1) the steps that seem to be most likely to trigger it are:
1 Click the attributes for criteria 1
2 Select an attribute for criteria 1
3 Click the attributes for criteria 2 (while the list of attributes from step 1 are still showing)
--> All attributes for criteria 2 are deleted
4 Select an attribute for criteria 2
5 Click the attributes for criteria 1 (while the list of attributes from step 4 are still showing)
--> All attributes for criteria 1 are deleted
6 Repeat steps 2-6 until the bug occurs
 
After a few rounds of this, the bug will usually occur.

Note: when testing this recently, I observed the following error after several rounds of this, but before the bug occurred:
Exception Access violation at address 004BC616 in module 'MediaMonkeyEngine.xe', Write of address 000000000. Would you like to restart MediaMonkey in safe mode?

I've attached the associated debug log (there was no crashlog). Note that although I'm always able to reproduce the bug, I've never seen this exception before.

EDIT: it seems that the exception occurs when I don't set a Limit to the query.

Ludek

2021-03-11 21:00

developer   ~0062394

Last edited: 2021-03-11 23:01

View 6 revisions

1) I was also able to replicate the crash and I also see the reason for the original issue now, to be fixed...

2) I am able to replicate (finally) by performing incremental search at first and then later check and uncheck an item, upon unchecking the item auto-scrolling to the last item appears (mostly).
To be fixed with cooperation with Michal in order to prevent from introducing a regression to Dropdown component.

michal

2021-03-12 14:10

developer   ~0062409

2) fixed in build 2324

Ludek

2021-03-12 16:56

developer   ~0062415

1&2 are fixed in 2324

peke

2021-03-13 19:02

developer   ~0062435

Verified 2324

Unable to replicate crashes in 2324 (it crashes on me in 2322)

peke

2021-03-23 23:39

developer   ~0062551

Re verified 2238

No regressions and unable to replicate.