View Issue Details

IDProjectCategoryView StatusLast Update
0016289MediaMonkey 5Track Browserpublic2020-01-31 18:22
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016289: Selection anomalies when Right-clicking selected tracks (regression?)
Description1 Navigate to an album [List] (or any other list view)
2 CTRL-A
3 Right-click on one of the selected tracks to perform a context menu action on all of them
--> The track becomes deselected!!
4 Repeat step 3
5 Left-click one of the deselected tracks
--> It becomes selected, but all of the other selected tracks also remain selected!
6 Left-click one of the selected tracks
--> It becomes deselected, but all of the other selected tracks remain selected!

In contrast:
1 Navigate to an album
2 Select 3 tracks
3 Right-click on a track
--> No change in selection (as expected)
TagsNo tags attached.
Fixed in build2224

Relationships

related to 0015638 resolvedLudek Renaming a genre sometimes causes selection to be reset 
related to 0015812 feedbacklowlander Deleted Comment remains on multi-file edit 

Activities

petr

2020-01-23 16:31

developer   ~0056176

We're unable to reproduce ...send more details and screencast, please.

rusty

2020-01-23 17:24

administrator   ~0056179

Here's a video that hopefully clarifies:
https://www.screencast.com/t/edSlcb75

rusty

2020-01-23 17:25

administrator  

right-click-deselects-selection.7z (117,308 bytes)

petr

2020-01-23 18:59

developer   ~0056183

This is exactly what we've tried, but cannot reproduce ... will check on any slower PC or so.

rusty

2020-01-28 21:52

administrator   ~0056331

Last edited: 2020-01-28 21:55

View 2 revisions

Could it be related to the fact that I tested in Touch mode around the time that this started occurring (steps 5 and 6 of this behavior is quite similar to how selection behaves in touch mode) ?

rusty

2020-01-29 14:52

administrator   ~0056380

EDIT: this issue is also easily replicated in grid views. e.g.
1 Navigate to Music > Genres [Grid]
2 Select Genre1 and Genre2
3 Right click on Genre2 > Auto-organize
--> Genre2 gets deselected and Auto-organize only applies to tracks from Genre1 !

rusty

2020-01-30 15:27

administrator   ~0056397

This was generated with a custom build from Petr:
https://www.screencast.com/t/Mrerm63Q

What's most interesting is that CTRL-A in a list view --> checkboxes superimposed on the list (this doesn't occur for multiple selection using the CTRL or SHIFT keys. It seems that when these checkboxes are shown, MM exhibits the same bugs (right-click deselection) as occurs in the Grid view.

petr

2020-01-30 15:55

developer   ~0056398

Fixed

rusty

2020-01-31 18:22

administrator   ~0056436

Verified 2224