View Issue Details

IDProjectCategoryView StatusLast Update
0015638MediaMonkey 5Track Browserpublic2020-10-25 13:58
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015638: Renaming a genre sometimes causes selection to be reset
DescriptionIn the course of testing 0015592, I've noticed the following occur periodically:

1 Select Genre: Psychadelic (in Genres view)
2 F2 to rename the Genre in-place to Genre: Psychedelic (which already exists for other tracks)
--> The Genre is renamed, but instead of an adjacent Genre being selected (e.g. Punk) after the view is completely reset and the first Genre in the view is selected!
TagsNo tags attached.
Fixed in build2176

Relationships

related to 0016289 closedpetr Selection anomalies when Right-clicking selected tracks (regression?) 

Activities

rusty

2019-05-03 18:18

administrator  

Ludek

2019-05-05 13:47

developer   ~0053420

It is not what I am seeing.

I renamed one song from 'Psychedelic' to 'Pychadelic' so that I see both genres like this:
https://www.dropbox.com/s/3f3qbxgzz5a4whw/Screenshot%202019-05-05%2015.43.35.png?dl=0
(where I selected 'Psychadelic')

Renamed 'Psychadelic' to 'Psychedelic' and got this:
https://www.dropbox.com/s/1hvhk4i1uensq3i/Screenshot%202019-05-05%2015.45.28.png?dl=0

i.e. 'Psychedelic' is focused (focus rectangle around) and no item is selected.

Ludek

2019-05-05 14:13

developer   ~0053421

Last edited: 2019-05-05 14:21

View 3 revisions

Nevertheless I see one regression that could cause the issue (caused by fixing 0013987).

View refresh (F5) causes the first item in the view being selected and focused!

=> Fixed in 2174

rusty

2019-05-10 18:01

administrator   ~0053479

I'm still able to replicate this issue in 2174. In this case after selecting and deleting a Genre (the last one in the log--one or two after 'Spin class'), the view reset. Note that this only occurs about 1/20 times.

rusty

2019-05-10 18:02

administrator  

bug15638_build-2174.7z (448,399 bytes)

Ludek

2019-05-15 09:31

developer   ~0053522

Fixed in 2176

peke

2019-05-17 22:56

developer   ~0053560

Verified 2176

Unable to replicate in 30 tries

rusty

2019-05-22 03:16

administrator   ~0053605

Verified 2176.

rusty

2019-05-31 04:49

administrator   ~0053678

The original problem seems to be solved, but there is still some strange / apparently non-deterministic behavior occurring re. selection:
- Select the first GenreName (via checkbox) and rename it to "" --> sometime the second Genre name gets selected (usually not)
- Select GenreNameA (via Checkbox) and rename it to GenreNameB --> sometimes the list remains in its current position, other times focus remains on the new GenreNameB moved to its new position.

Let me know if you prefer to defer this (in which case I'll move it to a new lower priority bug).

rusty

2020-01-29 14:49

administrator   ~0056379

No longer able to replicate this in 2223.

peke

2020-10-25 13:58

developer   ~0059989

Verified 2271

Unable to replicate