View Issue Details

IDProjectCategoryView StatusLast Update
0013987MediaMonkey 5Main Panelpublic2019-06-05 12:39
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Fixed in Version5.0 
Summary0013987: Art&Details panel "selected" content changes only upon clicking particular track
DescriptionUntil user selects a particular track then A&D content remains unchanged which looks strange when selecting non-track entities like albums, folders, artists, ratings.

a) Short term solution is to show properties of first track from the selected album/artist/genre

b) Long term is to show album/artist/genre properties
Additional Informationhttp://forum.mediamonkey.com/viewtopic.php?f=30&t=87045
TagsNo tags attached.
Fixed in build2176

Relationships

related to 0015566 closedLudek Search results: Should not show AA like track is selected 

Activities

Ludek

2017-02-06 18:46

developer   ~0047200

Fixed

rusty

2019-03-28 19:42

administrator   ~0053125

Tested 2067, and I'm not sure if it's implemented as intended. e.g.
1 Click Music> Artist > ArtistName > Track1
--> Artwork for Track1 displays
2 Click Music --> artwork for Track1 remains
3 Click one of the Artists displayed on the Music page
--> Artwork fails to update!

I've seen this occur for ArtistName album grid), Decade (Browser view) . It doesn't seem to occur for the Tracklist or Album & Tracks views.

Ludek

2019-04-02 12:52

developer   ~0053137

Last edited: 2019-04-02 13:10

View 3 revisions

This is related to 0015566 -- I think that Peke is right that in such a cases the A&D window should remain empty.
i.e. the bug here is that track from previous view remains in A&D after switching the view, it should reset to "no track".

Fixed in 2168

rusty

2019-04-09 15:46

administrator   ~0053166

Last edited: 2019-04-09 16:04

View 3 revisions

This seems to be a regression to me since the UI should be content-centric, but now the 'A&D' Selected window is always empty wasted space when searching for content or navigating nodes, until the user explicitly selects a track.

This could be ameliorated by:
- not showing null content if the user had previously selected a Now Playing track i.e.
. 1 Select trackA in NP list --> content displays in A&D
. 2 Search for X --> A&D switches to null content--it shouldn't since TrackA is still selected!
- collapsing the 'selected' Window automatically whenever no content is selected.

-Also, there's also a bug now, in Search > Tracks view (and presumably any tracks view). Upon performing the search, the first track is selected, but the A&D window fails to update with the new content.

There's a related issue that it's now a multi-step process to select content after navigating to a node/search result. The user should just be able to use the arrows to navigate to/select content. I'll open this in a new bug.
EDIT: on second thought, since selection handling is at the root of the issues above, it's worth discussing this here before opening a new bug: currently selection/focus is handled differently depending on the view: in tracks view / album & tracks view, the first track is always selected. In Browser view, no content is selected. The A&D Windows should always display content associated with whatever track is selected/in focus, which implies that it would work differently for these different views. We could go that route though I wonder whether it would be simpler and more consistent to just always select the first track and display it. Thoughts?

Ludek

2019-04-10 10:38

developer   ~0053172

OK, implemented in 2169

[Home > Music] --> track from Music collection is shown in A&D
[Home > Music > Artists] --> track from Music collection is shown in A&D
[Home > Music > Artists > ABBA] --> ABBA track is shown in A&D
[Home > Music > Genres > Rock] --> Rock track is shown in A&D

Note that this reverts 0015566

peke

2019-04-16 00:39

developer   ~0053234

Verified 2170

After review and comparing 0015566 This approach is better

rusty

2019-04-16 18:41

administrator   ~0053254

Last edited: 2019-04-16 18:41

View 2 revisions

Tested 2170. Looks good except:

1) in certain views where MM always displays a 'Selected' track that has nothing to do with either the Now Playing list or the active view--in these cases, MM always displays the first track in the Music > List view (in my case, '20 When you wish upon a star'. This occurs for:
Music (Browser view)
Music > Artists (Grid view)
Music > Albums (Art view)
Music > Genres

2) Similarly, in various 'browser' views, MM displays a track that has no apparent connection with either the first album or the first track in the view. e.g.
Artists>Beatles (Album Grid)
Genres>Alternative rock (Browser view)
Years > 1980s (Browser view)

For both of the above cases, MM should probably 'select' tracks based on what is actually displayed in the current view, preferring:
i) first displayed track
ii) first track associated with the first displayed album (if no tracks are displayed)
iii) first track associated with the first displayed artist (if no tracks or albums are displayed)

OR ALTERNATIVELY

i) first track associated with the first displayed item

NOTE: whatever MM displays as the 'selected' item, should also be shown in focus.

Ludek

2019-04-26 10:36

developer   ~0053381

Fixed in 2173

rusty

2019-05-06 16:50

administrator   ~0053433

Tested 2173 and most issues are resolved except:
1 The following views still always display '20 when you wish upon a star' in A&D (Selected) window (even though no related tracks/albums are shown in the view).
- Home (Browser view)
- Music (Browser view)

Ludek

2019-05-15 09:59

developer   ~0053523

Last edited: 2019-05-15 10:04

View 3 revisions

Yes, in the 'Music (Browser view)' it is sample track from the Music collection (representing a track from the first 'All tracks' node), see:
https://www.dropbox.com/s/lo4e6govq4eaeii/Screenshot%202019-05-15%2011.58.19.png?dl=0

Ludek

2019-05-15 15:14

developer   ~0053525

But thinking about it again, the "Collection grid" might be hidden in Browser view, so it would be better to auto-select the first artist in the artist row and the track associated with the artist.
=> Fixed in 2176

rusty

2019-06-05 12:39

administrator   ~0053732

Verified 2179.