View Issue Details

IDProjectCategoryView StatusLast Update
0015812MediaMonkey 5Properties/Auto-Toolspublic2020-02-09 18:16
Reporterlowlander 
PriorityurgentSeveritymajorReproducibilitysometimes
Status feedbackResolutionopen 
Product Version5.0 
Target Version5.0Fixed in Version 
Summary0015812: Deleted Comment remains on multi-file edit
DescriptionAfter deleting the Comment field value (leaving it empty) from multiple files the value remains for the first file.
Steps To Reproduce1) Open Properties for all Album file
2) Remove Disc#, Comment
3) Add Custom 1 & 4
4) Ok Properties dialog
5) Open Properties, Comment is still visible for the first file on Album
TagsNo tags attached.
Fixed in build

Relationships

related to 0015808 closedlowlander After MM restart Custom 1-5 are duplicated in Custom 6-10 
related to 0016289 closedpetr Selection anomalies when Right-clicking selected tracks (regression?) 

Activities

lowlander

2019-06-28 22:02

developer  

Comment Field doesn't delete.LOG (438,716 bytes)

Ludek

2019-07-02 21:15

developer   ~0054075

Last edited: 2019-07-02 21:21

View 2 revisions

I cannot replicate at all and based on the log review and code revision I haven't found a reason for the issue :-/

Are you sure that this is not a test error and that you have tested the newest build?
Can you re-test please?
Is the issue that really only the first track has still the comment?
Does the comment disappear after MM5 restart (or it also remains in the database and file tag)?
Is it related to particular album?
By "Open Properties for all Album file" you mean selecting all files in an album view, right-click > Properties?

Also, it would be helpful if you could catch this in a video so that I am sure that I am using exactly the same steps and see what the issue is.

lowlander

2019-07-19 20:48

developer   ~0054172

Yes, this is still reproducible and persists after restart.

Take an Album, select all files on it, open Properties. Remove Comment, update Custom 4. OK. Comment for file 1 still shows.

Comment Field doesn't delete 2.LOG (210,471 bytes)

Ludek

2019-07-23 10:47

developer   ~0054193

Last edited: 2019-07-23 10:48

View 4 revisions

I am testing directly on your database (where all is much slower) and still cannot replicate.

Questions:
1) On which album you are testing? In which view (node, view selected)? Could you attach at least screenshot? Ideally catching this in a video.
2) How exactly do you verify whether the comment is deleted or not?
3) Is the step of updating 'Custom 4' important to replicate the issue?
4) Did you wait until the progress bar with "X files to be tagged" and "X database entries to be updated" disappeared after the edit?

lowlander

2019-09-10 20:37

developer   ~0054583

1) Select album files in Location node.
2) Cut ID part of value in Comment.
3) Remove remaining part
4) Past value in Custom 4
5) OK Properies
6) Open Properties for Track 1, it still has original comment
All other files had the comment removed successfully

Ludek

2019-09-11 07:16

developer   ~0054589

Last edited: 2019-09-11 07:18

View 3 revisions

I still cannot repro whatever I do, but I am still not sure that I do the exact steps as you do (you haven't answered my questions in 0015812:0054193)
But rather than answering them -- could you please catch this in a video so that I can see exact steps (including view type / sub-view type etc) -- many tiny differences might be visible in the video (leading to replicating the issue).

Thanks!

Ludek

2019-09-13 09:04

developer   ~0054624

Please answer the following questions :
1) how exactly you entered the file properties dialog ?
2) is it issue just with the comment field -- or any other filed exhibits the same behaviour?
3) Is it refresh issue? i.e. if you press F5, does the comment disappear ?
4) Did you install the newest build to another folder than the previous MM builds? If not, could you try whether it helps?

rusty

2020-01-22 18:14

administrator   ~0056113

Martin, I suspect that this is just an instance of 0016289 (i.e. when you right-clicked on the first track to edit properties, it became deselected) . Can you confirm?

lowlander

2020-01-23 18:07

developer   ~0056181

Last edited: 2020-01-23 18:28

View 2 revisions

No, first file is selected and does have other metadata updated. I can reproduce with clean install using List View.

1) Navigate to Album folder in Location node
2) Select all files on Album
3) Right Click > Properties
4) Remove Disc# value (may not be required)
5) Cut part of Comment value (the ID part)
6) Remove remainder (Freedb: part)
7) Paste in Comment 4
8) OK Properties
File still has original Comment value



Emptied Comment Remains.zip (95,883 bytes)

rusty

2020-01-23 19:17

administrator   ~0056185

Unable to replicate :-( I'm just seeing similar problems in which the root issue is 0016289 .

Is it specific to a specific album / file type / view ? Perhaps create a video of this.

Ludek

2020-02-09 17:52

developer   ~0056590

Last edited: 2020-02-09 18:16

View 4 revisions

Try the following please:

1) Clean install MM5 2227 as Portable and scan just the one album (for which you could replicate the issue previously)
2) ZIP content of whole your /Portable/ folder and copy it to a temp location
3) ZIP content of the album files and copy it to a temp location
3) Run DbgView, run MM5 and try to replicate the issue within the album and indicate in which view you tested the mass edit
=> if you can still replicate then send me the ZIP of you Portable folder and the album files from step 2) so that I can replicate it too + debug log

Thanks!