View Issue Details

IDProjectCategoryView StatusLast Update
0016007MediaMonkey (current)Synchronizationpublic2019-10-16 04:39
ReporterLudek 
PriorityimmediateSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version4.1.25 
Target Version4.1.25Fixed in Version4.1.25 
Summary0016007: iOS 13 sync issues
DescriptionThere are some reports / logs showing slow sync for iOS 13 devices:
- Rusty's log in 0016003
- ticket #YZB-774-87453
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=12&t=95147
TagsNo tags attached.
Fixed in build1891

Relationships

related to 0016003 closedLudek Multiple instances of iPhone appear on connection 
related to 0012362 resolvedLudek Apple Device sync: Synchronization is progressively slowing down as during sync 
related to 0016017 closedLudek Sync: Iphone7 iOS 13.1.2 do not finish Scanning device 

Activities

Ludek

2019-09-30 16:20

developer   ~0054896

Last edited: 2019-09-30 16:22

View 2 revisions

Fixed in 4.1.25.1890

To be confirmed by Rusty and user from ticket #YZB-774-87453

Ludek

2019-10-01 09:23

developer   ~0054903

Last edited: 2019-10-01 11:18

View 8 revisions

Re-opened:

1) there is a regression in 1890 -- possible freeze when second sync is initiated without restarting MM

2) With iOS 13 some operations often takes a incredibly long time. e.g. AFCRenamePath, AFCFileInfoOpen takes 15 seconds (while they were instaneous prior to iOS 13).
This is especially problematic for our workflow, because we copy all files to intermediate folder beforehand and then we "commits" the files in batches while moving them to a proper location -- which makes the iOS 13 sync slow.
We would probably need to change the workflow completely (to be like iTunes workflow) which is very risky change for MM4 :-/
Details about the workflow differences are described here: 0012362:0041031

I am in process of finding a workaround/fix...

EDIT: Based on the user's log also many operations shared with iTunes sync workflow are incredibly slow (e.g. AMDServiceConnectionSend). So I guess that iTunes sync has the same issue (not fixable by us).

Ludek

2019-10-01 10:49

developer   ~0054904

1) is fixed in 1891

Ludek

2019-10-03 12:15

developer   ~0054921

Last edited: 2019-10-04 08:50

View 4 revisions

2) I can confirm the slow sync also with my iOS13 device.
While copying 84 files using iTunes took less than minute, the same 84 files took more than 15 minutes when copying using MediaMonkey !!
Searching for a solution....

3) We need to update the iTunes download links here http://www.mediamonkey.com/devicesync
It directs to "iTunes 10" download links that results in many issues:
a) It cannot be started when the "Windows Store" version of iTunes was previously installed (reports that the database was created by a newer iTunes version)
b) It does not support iOS 13
c) It breaks iMazing (iMazing throws error on start)

So please update the download links to "iTunes 12.10.0.7", the problem is that these version is not available on Apple sites for some reason, I downloaded it via a third party store (www.techspot.com in my case)

4) I would suggest to change the prompt
'An iPhone/iPod/iPad connection was detected. Please install iTunes in order to sync this device with MediaMonkey.'
-->
'An iPhone/iPod/iPad connection was detected. Please install iTunes Desktop version (not the Windows Store version) in order to sync this device with MediaMonkey. Click the Help button for assistance.'

Ludek

2019-10-04 08:53

developer   ~0054940

Last edited: 2019-10-04 09:23

View 2 revisions

2&4) are fixed in 1891

Assigned 3) to Rusty to update the download links to iTunes 12.10.0.7 desktop version and correcting/updating the KB article (re iOS 13 support).

rusty

2019-10-04 17:45

administrator   ~0054944

1) Verified
4) The suggested text looks fine.

Ludek

2019-10-04 22:05

developer   ~0054949

Last edited: 2019-10-10 12:56

View 5 revisions

3) Maybe it was my test error or Apple updated the links meanwhile, but it downdloaded iTunes 10 version when I was testing this (or maybe an older installer has been already downloaded in the same folder).

So let's just update the KB article to list iOS 13 support ( http://www.mediamonkey.com/devicesync ) with link to 4.1.25 version

rusty

2019-10-16 04:39

administrator   ~0055016

The article has been updated.