View Issue Details

IDProjectCategoryView StatusLast Update
0012362MediaMonkey (current)Synchronizationpublic2019-10-01 09:25
Reporterpeke Assigned To 
PriorityurgentSeveritymajorReproducibilityhave not tried
Status resolvedResolutionwon't fix 
Product Version4.1.5 
Target Version4.1.6 
Summary0012362: Apple Device sync: Synchronization is progressively slowing down as during sync
DescriptionAs I used factory reset device in testing of bug 0012360 I measured sync speed and concluded that it get progressively slower as sync progresses.

It goes fast (1 track per second) for about 15-20 tracks and than at 80+ it takes up to 15 seconds to sync single track.

U noted that scanning of device is on during whole sync process.

NOTE: Use logs supplied with bug 0012360
TagsNo tags attached.
Fixed in build

Relationships

related to 0012360 resolvedLudek iOS 8.1.1 failed sync 
related to 0013882 resolvedLudek iOS10 sync can fail when there is already 15.000 tracks on the device 
related to 0016007 resolvedrusty iOS 13 sync issues 

Activities

Ludek

2014-11-16 22:27

developer   ~0041031

Last edited: 2014-11-16 23:01

View 12 revisions

To clarify how this works:

The main difference between iTunes and MM sync workflow is that (starting from iOS5) iTunes sync all metadata for all synced tracks at first and then copies the individual tracks. So the initial phase of sync in iTunes is longer, but then the file copy operation is constantly fast for every file.

MM copies some files at first and then it commits its metadata, and this is done in batches. The first commit is after the first file copy, then after 20 seconds, and then every 40 seconds.

Therfore (in case of my test to copy 100 files) MM copies 1 file and commits (5 seconds), then copies further files during 20 seconds (50 files in my case) and commits (5 seconds), then it copies another 50 files in 30 seconds and commits (5 seconds). The overal sync time is 1 minute (same as with iTunes).

So it looks like if the file number 50 would copy 5 seconds, but it just commits metadata for another 49 files copied previously.

The reason for the different workflow is that we would need completely rework MM sync workflow (for all kinds of devices) to be compatible with the iTunes/iOS5+ sync workflow, or create this special workflow just for iOS5+ devices which would make the sync code hard to maintain.

Also there are some advantages of the MM workflow, the initial phase is not so long as in case of iTunes (e.g. in case user will want to cancel the sync)