View Issue Details

IDProjectCategoryView StatusLast Update
0015701MediaMonkey 5Main Panelpublic2022-08-05 09:54
Reporterpetr Assigned To 
PriorityurgentSeverityminorReproducibilityhave not tried
Status resolvedResolutionreopened 
Product Version5.0 
Target Version5.0.4Fixed in Version5.0.4 
Summary0015701: Menu issues in multi-monitor environments / windowing problem
DescriptionMain menu is opened always on primary monitor in multi-monitor environment when MM is maximized.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?p=458815#p458815

Issues re. context menu being truncated (as at step 5 of 0015701:0058981)
https://www.mediamonkey.com/forum/viewtopic.php?p=471057
TagsNo tags attached.
Fixed in build2659

Relationships

related to 0016804 assignedpetr MediaMonkey leaves trace on other monitor when maximized (multi-monitor) 
related to 0016913 closedpetr Menus are cut off when text size is 120% 
related to 0017935 resolvedrusty Options dialog appears in black and MM cannot be closed (focus issue?) 
related to 0016876 closedpetr Maximized dialogs display offscreen (offset to the right) in some cases 
related to 0016905 closedpetr Context Menu sub-menus open off-screen 
related to 0016941 resolvedpetr Multi-monitor + resolution change causes dragging of the MM window to fail 
related to 0016910 closedpetr File menu or dialog opens on wrong monitor 
related to 0017903 closedpetr Send to and FMFS menus always flash (?regression?) 
related to 0018007 closedpetr Main Menu responds inconsistently if MM is opened on a second screen (regression) 
related to 0018165 closedpetr Dialogs resize after switching between monitors 
related to 0018683 resolvedpetr Multi-monitor: MediaMonkey always opens on the 'Main display' when maximized 
related to 0018684 resolvedrusty Multi-monitor: Window can become unresizeable 

Activities

petr

2019-05-30 07:39

developer   ~0053661

Fixed

peke

2019-06-01 01:07

developer   ~0053702

Verified 2179

Tested on Virtual Second Monitor, now it opens in Focused monitor.

Close after user confirmation.

rusty

2020-07-15 17:59

administrator   ~0058981

Last edited: 2020-07-15 19:05

To summarize the issues that Peke is referring to, users are reporting that context menus don't appear in their expected locations in multi-monitor environments, specifically when the multiple monitors are of different sizes. I've been able to replicate incorrectly positioned context menus as follows (with build 2260):
1 Set laptop to extend primary screen to a monitor (WIN-P > Extend).
Settings are: 'Size of text, apps, and other items:' 150%, Primary: 1920x1080, Secondary: 3440 x 1440
2 Launch MM5 in primary window
3 Right-click on the tracklist in the primary window
--> Context menu appears adjacent to the cursor (i.e. correctly positioned)
4 Drag MM5 to the secondary window
5 Right-click on the left side of the tracklist in the secondary window
--> Context menu appears too far to the right with black artifacts surrounding it (see attached image below)!!
6 Right-click on the right side of the tracklist in the secondary window
--> Context menu appears too far to the left without the black artifacts (see attached image below)!!
7 Right-click on the left side of the player
--> Context menu appears on the Primary screen instead of the secondary screen (see attached image)!!

Note:
- The positioning issues / artifacts reported above do not occur with other apps' context menus (though I did notice one app opening the 'Save as...' dialog in the wrong monitor).

rusty

2020-07-15 18:06

administrator  

rusty

2020-07-15 19:07

administrator   ~0058982

Last edited: 2020-07-15 19:09

I've added step 7 (to my comment above) as I'm able to replicate the problem of getting the context menu to appear on the Primary screen even though MM5 is running in the secondary screen, by following the steps that drakinite described at:
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=96329&start=30#p469751

petr

2020-08-05 10:10

developer   ~0059242

Fixed

rusty

2020-08-13 18:06

administrator   ~0059389

Tested 2263 and now, the context menu displays correctly on the Primary screen, but on the secondary screen, it displays 396 pixels to the left of the cursor! Moreover, if the user right clicks less than 396 pixels to the left, the menu appears on the primary screen (instead of on the secondary screen)!

rusty

2020-08-13 18:07

administrator  

petr

2020-08-21 12:35

developer   ~0059447

Fixed

rusty

2020-09-22 17:50

administrator   ~0059637

Verified 2267.

rusty

2021-06-04 05:09

administrator   ~0063744

In 2411 a variant of the original bug occurs:
1 Set laptop to extend primary screen to a monitor (WIN-P > Extend).
Settings are: 'Size of text, apps, and other items:' 150%, Primary: 1920x1080, Secondary: 3440 x 1440
2 Launch MM5 in primary (OR secondary) window
3 Right-click on the tracklist in the primary window
--> Context menu appears adjacent to the cursor (i.e. correctly positioned)
4 Drag MM5 to the secondary (or primary) window
5 Right-click on a track in the secondary window (e.g. in Playing)
--> Context menu appears appears in the correct location, but a second orange outline appears at the upper left portion of the window and displays content that should be appearing in the main panel within this window instead!! This is really hard to understand, so watch the video.
6 Click on the menu
--> The 'weird window' disappears.

This 'weird window' is similar to the problem described in 0017935--perhaps they have the same root cause?

Video: https://www.screencast.com/t/TmadT2Z5

petr

2021-06-06 18:14

developer   ~0063787

Fixed

rusty

2021-06-09 04:55

administrator   ~0063832

This seems to be working well in 2413, but will need to reverify after 0018007 is fixed.

rusty

2021-06-10 00:52

administrator   ~0063884

Last edited: 2021-06-10 02:15

Verified that the issue re. the 'weird window' has been fixed in 2414, however, there's another problem; Switching (not moving) to secondary screen --> menus and window buttons display incorrectly:

1 Set laptop to extend primary screen to a monitor (WIN-P > Extend).
Settings are: 'Size of text, apps, and other items:' 150%, Primary: 1920x1080, Secondary: 2560 x 1080

2 Run MM on on the laptop (primary monitor)

3 Close the laptop
--> MM appears on the secondary screen but
a) Menus display incorrectly with a black box around them
b) Minimize / Maximize / Close buttons don't work (the 'hot spots' aren't positioned)

Note that these issues are resolved if MM is restarted, however, many users won't know how to close MM given issue b).

Note also that this is not a regression--MM 5.0.0.2388 exhibits the same problem. We can push to 5.0.2 if it's high risk.

rusty

2021-06-10 00:52

administrator   ~0063885

rusty

2021-06-10 20:54

administrator   ~0063891

Last edited: 2021-06-10 23:10

Partial fix has been implemented in 2415

Testing on a pre-2415 test build shows:
a) The menu problem persists.
b) The Window controls issue is partially fixed:
- The minimize/maximize/close buttons initially fails but starts working upon clicking an entry in the tree
Maximizing the window and then restore to the previous size
--> the buttons stop working again UNTIL clicking an entry in the tree

Recommend pushing to 5.0.2 since a) rarely occurs and is cosmetic and b) though serious, rarely occurs and can be worked around after a couple of clicks.

petr

2022-05-31 19:18

developer   ~0068352

Please retest in latest build as i've made some improvements in multi-monitor