View Issue Details

IDProjectCategoryView StatusLast Update
0017903MediaMonkey 5Main Panel: Toolbars & Menuspublic2021-07-18 20:22
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017903: Send to and FMFS menus always flash (?regression?)
DescriptionRight click on a track and then scroll to either 'Send to' or 'Find more from same' menus
--> the contextual menu flashes!

afaik, this is a regression (at least I never noticed it before).
TagsNo tags attached.
Fixed in build2411

Relationships

related to 0014673 closedpetr Incorrect initial popup window size 
related to 0015701 feedbackpetr Menu issues in multi-monitor environments / windowing problem 
related to 0018144 closedpetr Right click on video in Preview causes AV (regression 5.0.1) 

Activities

Ludek

2021-05-31 13:12

developer   ~0063627

Debugging this slightly and the flashing is caused by these lines in the popupmenu.js :

document.fonts.ready.then(function () {
   _this.windowSizeUpdate(true);

i.e. windowSizeUpdate is causing the flashing.

Ludek

2021-05-31 13:22

developer   ~0063628

Last edited: 2021-05-31 13:29

View 3 revisions

The flickering in the windowSizeUpdate was introduced by adding these lines in Petr's SVN revision 36337 (while fixing 0015701 ) :

if (usePopupMenuWindows && this.nativeWindow) { // to move window to correct position (in case target display have set different DPI)
    this.nativeWindow.setWindowBounds(l, t, 10, 10);
}

Removing these lines fixes the issue.

petr

2021-05-31 13:34

developer   ~0063630

Fixed

rusty

2021-06-04 04:35

administrator   ~0063741

Verified this fix 2411, however, there are issues with 0015701 (not sure if they're caused by this change or not).