View Issue Details

IDProjectCategoryView StatusLast Update
0014668MediaMonkey 5Syncpublic2020-10-11 19:53
Reporterrusty Assigned To 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0014668: Tweak Cloud profiles so that they're not so 'device' centric.
Description1) The dropdown for Scan for Media Files sometimes displays incorrectly (see attached)

2) For Cloud Storage, the 'Sync now' button triggers both a Scan and a Sync (depending on whether each is enabled). But it's a bit confusing since users looking at the 'Scan to Library' tab may not realize that pressing 'Sync' will trigger a scan. A solution might be:
a) Change wording: Scan to library --> Sync to library
b) Change wording: Scan for Media files periodically: --> Scan for media files:
c) Change wording: One time --> manually

3) 'Sync to remote' tab mentions 'devices' numerous times. Wording can be changed as follows:
a) Sync random subset of selected files up to device capacity --> Sync random subset of selected files up to capacity (this wording is also applicable to devices, so only a single string is needed)
b) Delete other files and playlists from the device: --> Delete other files and playlists from the target's storage

4) Some of the Options settings aren't relevant for cloud storage. I'm not sure which settings should be removed entirely for Cloud services (or whether it's specific to particular cloud services), so I'd ask you to review this. At a minimum, I can see a need for the following changes:
a) Should we remove the device profile ?
OR would it be better to:
- change Device Profile --> Service profile (only for cloud services)
- remove 'Lookup device online'
- change 'Import device options...' --> Import settings...
- change 'Export device options...' --> Export settings...
- change 'Reset device options...' --> Reset settings...
b) In auto-conversion settings:
- Change 'Format on PC' --> 'Format in Library'
- Change 'Format on Device' --> 'Format on target location'
- Supported formats on device --> Supported formats on target location
c) In File Locations
- Enforce use of sync mask for files already on the device --> Enforce use of sync mask for files already on the target
d) In Playlists, Generate device Playlists for: --> Generate Playlists on the remote target for:

5) The options panel has a missing graphic icon
TagsNo tags attached.
Fixed in build2098

Relationships

related to 0014983 closedLudek Cloud sync: further sync/scan sub-options 
related to 0015878 closedLudek Device config clearness issues 

Activities

Ludek

2018-03-13 10:01

developer   ~0049706

1) I don't see it and also don't see your attachement here. This used to be issue in older builds (< 2090), please retest with 2090+

2/2a) For me [Sync now] triggers only sync. [Apply] triggers the scan (in case you have checked the [x] Scan for media files checkbox)

2b) Fixed in 2091

2c) I guess 'One Time' is better, it is less confusing than 'manually' and corresponds to the same string in the Add/Rescan dialog (this is related to 0014272:0049406 )

3) Fixed in 2091

4a) Changed the suggested wording + used rather "Settings profile" and "Lookup settings..." strings (can be used for both devices and storages)

4b/c/d) Fixed in 2091

5) Fixed in 2091

peke

2018-03-16 21:43

developer   ~0049724

2b, 3, 4b/c/d, 5 Verified 2091

rusty

2018-03-19 22:27

administrator   ~0049751

Last edited: 2018-03-20 18:27

View 3 revisions

1) Verified

2a/b/c) So to refresh my memory: Unlike sync with a device, is bidi sync from the Cloud to MM completely independent of sync operations? And when the user clicks 'Sync Now', MM won't scan and sync new content on the drive to MM?
(this doesn't appear to be the case--see the image at 0014686--a sync to the Gdrive was initiated, and status bar seems to indicate that MM5 is scanning the Gdrive). Also see 0014690:0049766 .

If so, would it make more sense to:
i) Change 'Sync Now' to 'Scan now' (for this tab)?
ii) Remove the 'One time' option for 'Scan for media files'
iii) Change it back to 'Scan for media files periodically')?

3/4) Sorry to suggest some additional changes--seeing it implemented made me realize that it would be cleaner if we consistently used the language 'target':
3a) Sync random subset of selected files up to capacity --> Sync random subset of selected files up to target capacity
3b) Delete other files and playlists from the target's storage
 --> Delete other files and playlists from the target
3c) Sync to remote --> Sync to target
4b-i) 'Format on target location' --> Format on the target
4b-ii) Supported formats on target location --> Supported formats on the target
4b-iii) In the 'Compatible media formats' dialog: Select formats supported by the device --> Select formats supported on the target

Ludek

2018-03-20 21:32

developer   ~0049773

Last edited: 2018-03-20 21:41

View 5 revisions

re 2a/b/c)
Re: "Synchronizing Google Drive: (Scanning:)" - it is there before each auto-sync, it scans the actual GDrive content before sync, but isn't scanning anything into local MM library.

Maybe we could just remove [Sync now] button from the 'Scan to library' page and leave there only [Apply] to eliminate the confusion?

The reason why I would leave the "One Time" option there is for compatibility with the Add/Rescan dialog (as is done according to 0014272:0049406 )

Also, starting from 2093 remote playlists are scanned into local library per 0014272:0049760 . Maybe we should adjust the string accordingly (i.e. [x] Scan for media files and playlist ) and add a tooltip so that users are aware what the scan does?

rusty

2018-03-21 12:58

administrator  

scan_for_media_is_collapsed.jpg (41,861 bytes)   
scan_for_media_is_collapsed.jpg (41,861 bytes)   

rusty

2018-03-21 19:45

administrator   ~0049786

1) See attached--captured from build 2093

2 a/b/c) Per Ludek's explanation, in MM5 'scanning' can mean different things:
- In the Device & Services setup it refers to scanning cloud content to the library (kind of like bi-di sync)
- In the sync status messages, it refers to checking the remote target for changes without adding content to the library.

Also, although in the current implementation, Scanning (of content/edits into the library) is only triggered by manually initiated or scheduled scan operations, in the near future, the plan is for such updates to occur:
- automatically/incrementally any time changes are made in MM5 to cloud content
- automatically any time a sync operation is initiated

Assuming our implementation matches the above, I would suggest the following (superseding comments at 0014668:0049751 re. 2a/b/c):
- "Synchronizing Google Drive: (Scanning:) --> leave as is since scanning operation will in fact be performed during a sync.
- Scan for media files: --> Scan for media / playlists on sync and __________^
- One time --> manually (note: this can apply for the scanning dialog as well for all storage locations)

3/4) See comments at 0014668:0049751

Ludek

2018-04-05 13:18

developer   ~0049880

Last edited: 2018-04-05 17:01

View 10 revisions

1) I see, I can reproduce it now when I delete /Portable/ folder and start clean install (without importing from MM4).
EDIT: Seems to happen whenever "zoom in" view animation is involved. i.e. when clicking the cloud storage directly in the "Storage & Services" view (not via media tree)
=> Fixed in 2094

2) One time --> manually (note: this can apply for the scanning dialog as well for all storage locations)

As discussed offline, "Manually" should be used for all items (including local folders) on the attached screengrap (OneTime.png).
=> Fixed in build 2094

3/4) Fixed in 2094

Ludek

2018-04-05 13:18

developer  

OneTime.png (52,307 bytes)   
OneTime.png (52,307 bytes)   

rusty

2018-04-12 01:37

administrator   ~0049925

Tested 2095, and I see a couple of typos/minor issues:

2)
- Scan for media / playlists on sync and __________^ --> Scan for media / playlists on sync __________^
- Manually --> manual

Ludek

2018-04-17 14:22

developer   ~0049977

Last edited: 2018-04-17 17:35

View 2 revisions

Fixed in 2098

rusty

2018-04-18 21:51

administrator   ~0050009

Verified 2098.

Ludek

2018-07-10 09:25

developer   ~0050733

Last edited: 2018-08-12 11:23

View 3 revisions

It seems that "Scan to Library" / "Sync to target" terminology is confusing for users, details at: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&p=447239#p447236

Especially in a GPM context, where both source and target are "libraries".

Further (new feedback) here: https://www.mediamonkey.com/forum/viewtopic.php?p=448318#p448318

rusty

2018-09-07 21:22

administrator   ~0051058

I've suggested UI changes at 0014983--let's continue the discussion there.

peke

2020-10-11 19:53

developer   ~0059806

Verified 2269

as 0014983 is already tested and closed I only compared and checked if something was missing. No missing parts Closing