View Issue Details

IDProjectCategoryView StatusLast Update
0014690MediaMonkey 5Syncpublic2020-08-18 03:20
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0014690: Failed Manual Sync to Google Drive / Uncaught error: "Cannot read property 'id' of undefined"
DescriptionIn testing #13571, I:
1 Deleted media content (/MediaMonkey, /Music, /Playlists directories) from Google Drive (using the Chrome Browser)
2 Selected an Album in MM5 and used Send To > Google Drive
--> Content appeared to sync successfully to Google Drive (even though it didn't actually copy--see first note below)
3 In MM5, navigated to Folders > Google Drive
--> Uncaught error: "Cannot read property 'id' of undefined"
TagsNo tags attached.
Fixed in build2093

Relationships

related to 0014686 closedLudek Sync to Google drive --> crash 

Activities

rusty

2018-03-20 17:35

administrator  

cannot_read_id_of_undefined.jpg (114,758 bytes)   
cannot_read_id_of_undefined.jpg (114,758 bytes)   

rusty

2018-03-20 17:43

administrator   ~0049761

Last edited: 2018-03-20 17:48

View 3 revisions

I was wondering if perhaps this is related to the fact that the media files need to be manually scanned in order for them to be visible in the library, so I tried restarting MM and initiating a scan from Devices & Services > Google drive. Doing so resulted in the same error occurring.

Also, an examination of the Google Drive using chrome shows that No Content synched to Gdrive!!

Could it be a problem regarding the profile? i.e. the fact that the /MediaMonkey directory was deleted in Google Drive but the Sync Profile in MM5 wasn't reset (the json file in the gdrive/MediaMonkey directory wasn't recreated)?

rusty

2018-03-20 17:56

administrator   ~0049762

I subsequently signed out of Google Drive in MM5 (from from Devices & Services > Google drive) and then signed back in, and manually synced an Album again. As before, the tracks appeared to sync, but an examination of the drive in chrome shows that nothing actually synced.

rusty

2018-03-20 18:26

administrator   ~0049766

Further testing reveals some very strange behavior:
when re-ordering tracks in the Playlist panel
--> this error occurs
--> "Synchronizing Google Drive: (Scanning:)" appears in the status bar

Even though you've figured out the root of the various errors (the fact that they're caused by the tracks remaining within Google Drive's recycle bin) it's very strange that 'Synchronizing Drive: (Scanning)' appeared especially considering that Scanning wasn't enabled.

Ludek

2018-03-20 18:38

developer   ~0049767

Last edited: 2018-03-20 18:38

View 2 revisions

Yes, items in Chrome's "Recycle bin" has no parent items and are cause of this error. i.e. I can replicate finally using "remove" in Chrome

Re: "Synchronizing Google Drive: (Scanning:)" - it is there before each auto-sync, it scans the actual GDrive content before sync, but isn't scanning anything into library.

Ludek

2018-03-20 19:43

developer   ~0049769

Fixed in 2093

Ludek

2018-03-20 19:57

developer   ~0049770

Last edited: 2018-03-20 20:35

View 2 revisions

Re-opened: The issue with copying tracks to the recycle bin's version of the folder persists.

=> Fixed in 2093

peke

2018-03-21 02:57

developer   ~0049776

Verified 2093

peke

2020-08-18 03:20

developer   ~0059433

Verified 2264

Unable to replicate Drive plugin works ok for me.