View Issue Details

IDProjectCategoryView StatusLast Update
0014264MediaMonkey for AndroidUPnP / Castingpublic2019-09-20 18:18
Reporterrusty 
PriorityurgentSeveritymajorReproducibilitysometimes
Status resolvedResolutionreopened 
Product Version1.3.1 
Target Version1.3.2Fixed in Version1.3.1 
Summary0014264: Play to chromecast stops periodically
DescriptionWhen playing to a chromecast audio, there are reports that playback often stops, and that periodically no data is displayed for the playing track.
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=87842 (debug log included in the report).

Upon testing playback for about an hour or so, I was able to replicate the problem--playback just stops periodically in the middle of a track. An example of this is contained in the following log:
7VE4WGQWNY
TagsNo tags attached.
Fixed in build724

Relationships

related to 0013978 closedmartin MediaMonkey for Android MMA shows wrong song in Now Playing when Chromecasting with Shuffle enabled 
related to 0014278 closedmartin MediaMonkey for Android MMA crashes upon initiating chromecast playback 
related to 0014545 resolvedmartin MediaMonkey for Android False error messages re. inability to play tracks to chromecast when pressing NEXT slowly 
related to 0014636 resolvedmartin MediaMonkey for Android Migrate CCL Sender to Cast SDK v3 
related to 0014971 closedpetr MediaMonkey 5 Auto-update feature with combination of Now Playing Undo causes gaps between tracks to be played 
related to 0014474 closedmartin MediaMonkey for Android Starting a call stops Chromecasting 
related to 0015967 assignedmartin MediaMonkey for Android Chromecast Playback stops periodically (fix with new CC libraries) 

Activities

martin

2017-06-19 22:48

developer   ~0048161

Fixed in build 1.3.1.704

rusty

2017-06-20 18:14

administrator   ~0048170

This is much improved, though it has occurred occasionally in build 704. I'm still testing to determine whether it's random or related to connection issues.

rusty

2017-06-21 15:08

administrator   ~0048207

Tested 705 and it generally seemed to work well, except in one case it stopped at the after 'Take this Waltz' at the beginning of 'Why Worry'.
Debug log: HKWUY3UV8Z

The reason for this probably because "Why Worry" is an .ape track and can't play on a chromecast. Unfortunately, instead of just skipping that track, MMA stops playback.

Then, pressing Play attempts to restart playback, but results in every single track in the NP list skipping with a toast message for each track:
'Skipped X. It is unsupported by the receiver.'
This is really quite bad as there doesn't seem to be a way of halting this as MMA tries and fails to play every track in the list.
Debug log: DSYWK92F8T

Only if chromecasting is disabled/re-enabled does it start working again.

rusty

2017-06-21 21:55

administrator   ~0048213

Note: testing with other 3rd party players didn't cause the chromecast device to lock up / keep skipping tracks. It just failed to play the problematic track--though I had to manually advance to the next track.

Would make sense to stop MMA from attempting to play any formats that it doesn't support (though this is only a partial workaround).

Side note: the ape track in question shouldn't have been synced to MMA in the first place, since APE is an unsupported format on the device--I'm testing why/how that occurred.

martin

2017-06-22 15:34

developer   ~0048225

At first, it's not due to ape tracks, but due to mimeType "application/octet-stream". I have added converter to "audio/ape" (depending on file extension) and playback works now on chromecast.
Also I have added workaround when chromecast lock. Maybe it depends on Chromecast device, but same behavior with Google Music Play and GoneMad player.

Fixed in build 1.3.1.706

rusty

2017-06-23 20:39

administrator   ~0048238

This crash still occurs in build 707, however, I'm unable to generate a debug log since 0014278 is preventing chromecast playback without crashing, thereby preventing me from generating a log of this.

On a couple of occasions when I was able to bypass 0014278, though, this bug was still occurring.

rusty

2017-06-25 02:27

administrator   ~0048255

This seems to be fixed in 708 (likely as a result of the fix to 0014278.

rusty

2017-08-04 23:53

administrator   ~0048468

Unfortunately, this still seems to be occurring periodically in build 720. What happens is, playback works correctly for awhile, then stops in the middle of a track. Then after some indeterminate period of time (30s to 2m to never) playback resumes.

Debug log: G4V96SINSP (sent soon after playback stopped)

martin

2017-08-07 16:22

developer   ~0048475

From the log, I see that cast device stuck in buffering state. Unfortunately, I don't know a reason. I can't replicate it. Does it happen always with the same track or randomly? Does it occur with BubbleUPnP?
I think the cause is not on MMA side, but I will be testing it.

rusty

2017-08-07 20:17

administrator   ~0048478

Last edited: 2017-08-07 20:25

View 2 revisions

fyi, the problem tends to occur after playing MMA for some time (e.g. 20m). It occurs with various different files (there was no common denominator that I was able to observe, but I'll retest).

Thus far I've been unable to replicate with BubbleUPnP, but I'll test further.

One possibility: could it be related to 'lookup missing album art' ?

martin

2017-08-08 10:30

developer   ~0048489

re relation: I don't think so.
I have tested it several hours and still no issue on my devices.

rusty

2017-08-08 17:44

administrator   ~0048490

Last edited: 2017-08-08 18:54

View 2 revisions

I was able to reproduce it on an Honor 5x running Lineage OS 14 (Android 7.1). Playback stopped and didn't resume on track 'All the things I wasn't'.
Debug log: 5LSDYG8EYC

rusty

2017-08-08 18:54

administrator   ~0048491

I just replicated the problem on Android 6 running on an S5 mini. Playback stopped (and didn't resume) on track "Bo'ee". Debug log: 1M3G5A6G8Q.

martin

2017-08-11 14:51

developer   ~0048514

Fixed in build 1.3.1.722

rusty

2017-08-13 17:02

administrator   ~0048531

Tested build 722 and although failures seem to be more sporadic, they still occur ~once per hour.

Tested on a Nexus 5x / Android 7.1.

Log ID: RTQFUR6JUH
Description: chrome casting stopped at 5 days in May

Log ID: CNNKEIKXGW
Description: Chromecast stopped at doolin daltons

martin

2017-08-24 14:40

developer   ~0048573

Fixed in build 1.3.1.724

rusty

2017-08-30 14:11

administrator   ~0048617

Last edited: 2017-08-30 16:37

View 3 revisions

In build 724, chromebook playback seems more stable in the sense that enabling/disabling casting works just as expected (no delays). However, After about 30 minutes, chromecast playback paused for about 10 seconds in the middle middle of a track: hebrew track
Debug log: 4XH334K4VK

The same happened for the next track: The Boxer - Simon and Garfunkel
Debug log: DQCL8V8IPM

When I subsequently presses 'Next' to advance a track and/or replay those tracks, playback worked as expected. In other words, it seems that 'something' triggers the bug and that once triggered, MMA/Chromecast devices enter into a state where the bug is more likely to occur. Pressing Next/Stop seems to "reset" MMA playback until the bug next occurs.

I'm continuing to test to see if the problem recurs with other tracks.

Note: the tracks being played are all MP3 128-192 Kbps (VBR and CBR).

rusty

2017-08-30 14:20

administrator   ~0048618

After about 10 minutes of playback, the problem occured again with 'The house of the rising sun' by the Ventures. Playback paused for about 60 seconds and then resumed. This time I generated the log after playback resumed: 1JV4IJNPYI

rusty

2017-08-30 16:39

administrator   ~0048620

Further testing with several other chromecast-capable apps revealed similar issues. So I'm tempted to suggest that the problem is related to either my environment or to chromecast APIs.

martin

2017-08-30 17:18

developer   ~0048621

Last edited: 2017-08-30 17:19

View 2 revisions

I agree that issue is NOT on MMA side.
In all your logs chromecast get stuck in "buffering" state.
Current MMA version tries to detect this case and fires "play" action to reduce delay.

rusty

2017-08-30 20:01

administrator   ~0048627

Last edited: 2017-08-30 20:02

View 2 revisions

This thread seems to confirm that as well:
https://productforums.google.com/forum/#!topic/chromecast/BgByQTW98mM;context-place=topicsearchin/chromecast/1.22$20beta

Leaving this issue as 'resolved' for testing with new chromecast firmware in the future (current tests were with 1.2.6.94126).

peke

2017-11-15 00:01

developer   ~0049176

Can't replicate on Google Payer Android TV 8.0 Oreo and Google Cast v1.27.96538 Using both MM5 and MMA 738

rusty

2017-11-15 17:11

administrator   ~0049185

Tested with build 739 vs group of 2 chromecasts running firmware 1.28.100555. No interruptions in a two hour span.

Closing.

rusty

2018-03-26 02:42

administrator   ~0049803

I'm still seeing this issue often with build 751. When I observed it today, playback stopped, and then attempting to restart resulted in missing codec errors for all subsequent tracks.

Is this already fixed in 1.3.2?

martin

2018-03-26 08:01

developer   ~0049806

Last edited: 2018-03-26 08:01

View 2 revisions

1.3.2 version uses new Cast SDK v3 instead CCL. All chromecast issues have to be tested with version 1.3.2.801 or newer.

rusty

2018-04-05 18:12

administrator   ~0049887

This issue persists with MMA 1.32.803 (tested on both Chromecast Audio and Chromecast G2).

Note that the tracks after which playback stops are random--on subsequent attempts those tracks will play fine and playback will stop on a different track.

Log ID: KKU5KX85GL
Description: Chromecast randomly stops after track plays

martin

2018-04-06 08:00

developer   ~0049889

Last edited: 2018-04-06 08:30

View 2 revisions

Can you confirm that playback stops during a transition between tracks(When next track should start play.)?
Does it occur with Bubble UPnP player?
Do you have shuffle enabled?

rusty

2018-07-20 23:44

administrator   ~0050796

In build 821 playback paused several times in the middle of a track (I didn't observe this with build 819, but I'm not sure if this was just coincidence).
Log ID: VVBALYSWBW

martin

2018-07-22 21:57

developer   ~0050798

In the log playback paused due to "onSessionSuspended". It means connection issue or some Chromecast issue, but no issue on MMA side.