View Issue Details

IDProjectCategoryView StatusLast Update
0015967MediaMonkey for AndroidPlaybackpublic2019-11-14 23:26
Reporterrusty 
PriorityurgentSeveritymajorReproducibilitysometimes
Status resolvedResolutionreopened 
Product Version1.3.5 
Target Version1.3.6Fixed in Version1.3.6 
Summary0015967: Chromecast Playback stops periodically (fix with new CC libraries)
DescriptionWith build 866 running on Android 10, if playback is output to the chromecast, then it stops periodically (e.g. after 30 minutes)--I think it was upon completion of the track.

Here's a debug log from when this happened a week ago:
Log ID: NRVGHK157U
Description: Chromecast playback stopped

Another one from when I just replicated it (after 'Moby - Then it fell apart'):
Log ID: HCKTCEHF86
Description: Chromecast playback stopped

And a third one that shows what happens immediately afterwards i.e.
1 Press Play / Next --> playback doesn't resume
2 Press 'Stop Chromecasting', and then press Play --> playback resumes
Log ID: 4NC7C1Z93H
Description: multiple attempts to restart Chromecast playback fail. playback only resumes once Stop Chromecast is clicked.

Note also the issue isn't track specific--I confirmed this as follows:
- I played the track by Moby - It fell apart' without chromecasting enabled, and playback didn't stop.
- I then played the track again with chromecasting enabled, and playback didn't stop.
TagsNo tags attached.
Fixed in build883

Relationships

related to 0014264 resolvedmartin Play to chromecast stops periodically 
related to 0015977 resolvedmartin Migration to androidX 
related to 0014788 resolvedmartin Casting: repeats track before it proceed to next one 

Activities

martin

2019-09-23 11:50

developer   ~0054793

I can see "Could not send response to the client" in your logs.
It looks like chromecast device stoped working in this case.
My experience is that chromecast devices are quite unstable sometimes and MMA is not able to fix all weird situation.

Tested with my chromecast and after 2 hours MMA is still playing.

Also MMA 2.0 will have to migrate to newest androidX libraries, which replaces the original support library APIs. So another deep testing of chromecast will be requiered with 2.0 version.

rusty

2019-09-23 15:06

administrator   ~0054803

This only occurs for me periodically as well. Hopefully the new libraries in MMA 2.0 will solve this.

martin

2019-11-13 18:29

developer   ~0055334

Fixed in build 1.3.6.0882

peke

2019-11-14 02:34

developer   ~0055345

Verified 882

No stops after 3h playback

rusty

2019-11-14 05:40

administrator   ~0055347

Last edited: 2019-11-14 06:05

View 6 revisions

MMA build 882 crashes everytime I initiate chromecast playback on a Pixel 2 (Android 10).

Playback to CC Group: 2 auto-crashlogs + 1 manual log: R7UA53MVQQ
Playback to individual CC: 1 auto-crashlog + 1 manual log: 5KSQXBQMR3
Crash on chromecast activation (no playback): 1 auto-crashlog + 1 manual log: TA1FHMMCMD

These crashes do not occur with this build on an S8 running Android 9 or a Nexus 5x running Android 8, so it must be something specific to Android 10.

martin

2019-11-14 23:26

developer   ~0055356

Fixed in build 1.3.6.883