View Issue Details

IDProjectCategoryView StatusLast Update
0013741MediaMonkey 5DB / Backuppublic2020-11-13 01:09
Reporterpeke Assigned To 
PrioritynormalSeveritymajorReproducibilityN/A
Status closedResolutionno change required 
Summary0013741: Album Art: Handling Linked Album art
DescriptionLinked Album arts are not cached locally in MMW 4.x Cache So when user disconnect NAS or unmount network folder. it is not possible to show/manipulate album art for tracks and some tracks show without Album Art 0013386 even it has it as Linked one.

Solution for that would be to Cache Linked Album Arts Especially if Tracks exist in Virtual CD

Also not available Album art should be ignored on Metadata update and user would need to be presented with warning that he is removing non accessible album art
TagsNo tags attached.
Fixed in build

Relationships

related to 0013386 closedLudek MediaMonkey (current) Album Art: Track on Non Connected HDDs can throw error on album art edit 
related to 0010639 new MediaMonkey (current) Album Art view: MMW should be able to cache all Album arts in library 
related to 0010640 new MediaMonkey (current) Maintan library: Selection of common maintan tasks 
related to 0013742 feedbackLudek MediaMonkey 5 Album Art: inaccessible artwork should be superceded by available artwork 
related to 0016683 newrusty MediaMonkey 5 Artwork: no way of knowing when linked artwork is missing 

Activities

jiri

2016-12-12 16:47

administrator   ~0046484

Is this important? I mean while the track isn't accessible for playback, do we need its artwork?

Note that this should work fine for Album-based browsing, e.g. in Albums view in MM5, as the album artwork is cached, but I don't think it's necessary per track.

peke

2016-12-16 00:44

developer   ~0046553

Track is Accessible in Virtual CD, also it is possible to Add linked album art from portable drive and then disconnect drive making it non accessible or maybe drive letter is changed so again non accessible.

peke

2020-05-07 09:12

developer   ~0057885

Not an issue in MM5 as MM5 removed Virtual CD function and Album arts are Cached differently

rusty

2020-05-13 02:11

administrator   ~0057973

This seems to be irrelevant for MM5.

peke

2020-11-13 01:09

developer   ~0060166

Revised 2273

Not needed in MM5, new bug should be opened if needed as it will be different issue.