View Issue Details

IDProjectCategoryView StatusLast Update
0006739MediaMonkey (current)Framework: Taggingpublic2010-12-07 22:20
Reporterrusty 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006739: Field Mapping Tweaks
DescriptionUpon discussion, there was agreement that the following guidelines should be followed in terms of mapping fields depending on file type. There are _NO_ other fields with such mappings in MM4 other than those described below:

1. Album = Podcast = Series - i.e. these fields would share the same value internally in MM.

2. Artist (Music) = Director (Video/TV) - internally, however Director should have its own suggestions in the dropdown (i.e. don't share them with Artists in Music)

3. Lyricist (Audio) = Screenplay Author (for Video/TV) i.e. these would share the same value internally in MM, but would have their own suggestions in the dropdown. Ideally, this field would always appear on the Basic properties screen. For Video type it would replace Lyricist as used in Music.

4. Note that Artist |= Actor internally i.e. the Properties UI showing 'Artist (actor1; actor2)' should be modified to 'Actor(s)', so that it's clear that it doesn't store values in Artist field. Note that this field should support multiple values (in the same way as Artists and other multiple-value fields).
TagsNo tags attached.
Fixed in build1329

Relationships

related to 0006575 closedLudek Different content Types should have different Properties window layouts 
related to 0006795 closedrusty Colums: Names are incorrect for collections 
related to 0006796 resolvedrusty Tree nodes: Video/TV Collection default nodes 
related to 0006936 closedLudek Find more from same should be adapted to Video 

Activities

Ludek

2010-11-24 12:01

developer   ~0021445

Note that this involves to add new internal fields for
- Producer (DB table Artists with PersonType = PT_PRODUCER)
- Actors (DB table Artists with PersonType = PT_ACTOR)
- SeasonNumber
- EpisodeNumber

Ludek

2010-11-25 16:13

developer   ~0021475

Fixed in build 1328.

Ludek

2010-11-26 08:31

developer   ~0021483

Last edited: 2010-11-26 08:54

View 2 revisions

Fixed for tagging, properties mass edit + added Scenarist column in build 1329.

zvezdan

2010-12-01 08:16

updater   ~0021531

http://www.mediamonkey.com/forum/viewtopic.php?f=4&t=53032

I am not so over-hyped with this new video support of MM4. I don't need a new video player. No disrespect, but I doubt that you could make it better than The KMPlayer. Especially not with your politics about codecs. The KMPlayer, PotPlayer, VLC, SMPlayer and many others could play almost any audio/video file without any problem since they have all codecs included. Have you implemented subtitles support? Without that many non-English users would not use it either.

Actually, I want to replace the movie database management software which I am using right now - Ant Movie Catalog (http://www.antp.be/software/moviecatalog/) because it is not actively developed anymore. So, since you are updating the database structure to accommodate some of the video related fields, have you really included all needed fields for video database management? You see, it is not only about Actors/Directors/Producers/..., but also with video technical data. MM should be able to take technical data from video discs/files (resolution, fps, video bitrate, used video/audio codecs, number of disc/files, ...) when you use the Add/Rescan Tracks option and to store that data into appropriate fields.

There are also many other non-technical fields related to movies which your database don't have, e.g. Storyline, Translated Title, Country, Spoken Language, Languages of all related Subtitles, ... Please take a look at AMC's screenshot (http://www.antp.be/pic/moviecatalog_main.png) if you didn't try that software and see which fields are really needed for video database.

You should also add related API methods/properties, mainly to the ISDBSongData object (SongData.Actor, SongData.Country, ...), if you want support from scripters, for example if someone wants to write add-on for taking data from IMDb.

rusty

2010-12-01 20:21

administrator   ~0021539

Tested 1329. Leaving 'fixed' for Peke to verify all tagging functionality.

rusty

2010-12-06 20:20

administrator   ~0021626

Peke verified all tags. Closing.

peke

2010-12-07 22:07

developer   ~0021653

Last edited: 2010-12-07 22:09

View 2 revisions

Reopening I noticed few slow downs on tagging with files that already have tags in them.

peke

2010-12-07 22:17

developer   ~0021654

Assigned to me until few more tests are done.

peke

2010-12-07 22:20

developer   ~0021655

Verified 1331

I had few same Lyricist and Screenplay Author that confused me.