View Issue Details

IDProjectCategoryView StatusLast Update
0006575MediaMonkey (current)Tracklistpublic2010-12-03 05:24
Reporterrusty 
PriorityimmediateSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006575: Different content Types should have different Properties window layouts
DescriptionDepending on the Type of a file, the Properties window should be optimized to display the relevant fields (Types refers to: Music, Classical Music, Video, Music Video, TV, Podcast, Audiobook).

Note: aside from the Properties layouts, other File-specific optimizations include Player rules (0006572) and Summary format (0006571).

Open Issues not yet addressed by the spec:
i) The proposal doesn't currently address mapping of Type-specific metadata to tag formats (i.e. which tags will be used). This needs to be specified. We also need some sort of specification outlining which tags are relevant for each format (the current spec only defines 'basic' tags).

ii) The proposal assumes that the second 'Details' panel will allow the user to configure whatever fields are relevant using a new UI by dynamically populating a grid control with fields relevant/taggable for the content Type in question (alternatively, the details screen will need to be modified / laid out for each content Type).

See attached images for a proposal of how this can be laid out.

General comments:
- In the Properties dialog, small fonts for field descriptors placed above fields, in order to avoid the currently confusing layout in which some fields have descriptors below the fields.

- In the Properties dialog, the Type field should be superior to the tabs because changes to it will trigger changes to the tabs and to the layout of the dialog (e.g. Switching from Type=Music to Type=Video would get rid of the Virtual CD tab). The attached graphics show a proposed layout, but if it is too much work to position the dropdown at the level of the tabs, we'll have to incorporate it below the tabs (e.g. Top-right corner of the 'Basic' tab).
TagsNo tags attached.
Fixed in build1330

Relationships

related to 0006570 closedLudek Tracklist tooltips should display more content 
related to 0006573 closedLudek Mass Edit of multiple Types of files 
related to 0006574 closedpetr Track Browser Configurability Per Collection 
related to 0006739 closedLudek Field Mapping Tweaks 
parent of 0006569 closedpetr New icons / images for various Collections / Tree nodes 
parent of 0006571 closedpetr Title summary should vary dependent on content Type 
parent of 0006572 closedLudek Per Type Playback Rules for Auto-DJ & Track Addition 
related to 0006579 closedpetr UI Simplification: Remove 'Views' from Collections Options 
related to 0006588 closedpetr Default Art & Details View Settings by Type 
related to 0006777 closedpetr Collection Default settings 

Activities

rusty

2010-10-20 22:50

administrator  

properties_classical.png (192,971 bytes)
properties_classical.png (192,971 bytes)

rusty

2010-10-20 22:50

administrator  

properties_music.png (128,150 bytes)
properties_music.png (128,150 bytes)

rusty

2010-10-20 22:51

administrator  

properties_video.png (97,092 bytes)
properties_video.png (97,092 bytes)

rusty

2010-10-20 22:51

administrator  

properties_podcast.png (66,317 bytes)
properties_podcast.png (66,317 bytes)

jiri

2010-10-22 20:22

administrator   ~0020902

As discussed over e-mail, assigning to Ludek (with parts to be possibly done by Petr).

Mizery_Made

2010-10-22 22:43

updater   ~0020919

Pardon the interruption, but I notice in the Details tab mock-up that Involved People may/will get a face lift. Is this a sign of further improvements regarding the field? I started a Wishlist thread regarding the field a few years ago, which I think presented some good ideas for it: http://www.mediamonkey.com/forum/viewtopic.php?f=4&t=35543

jiri

2010-10-23 01:25

administrator   ~0020924

It probably won't get into 4.0, but it's definitely planned to be implemented soon, i.e. either 4.0 or 4.1.

Ludek

2010-10-25 11:05

developer   ~0020940

Last edited: 2010-10-25 11:07

View 2 revisions

Added the new Properties type-based layouts in build 1319.
i.e. Properties dialog now supports multiple Layouts (including their live switching).
Except for the advanced tags and Involved people improvements, but I am working on it.

Ludek

2010-10-25 11:06

developer   ~0020941

Last edited: 2010-10-25 11:07

View 2 revisions

Re-opened in order to add the default values for individual Collection views.
Assigned to Petr.

rusty

2010-10-25 22:36

administrator   ~0020986

Re-tagged as resolved--will open a new bug for Collection default settings.

rusty

2010-12-01 20:16

administrator   ~0021538

Tested build 1329, and it's generally functioning well. Re-opening for some tweaks/corrections to the Properties dialogs:

Music:
------
Should just show 'Artist' instead of 'Artist (ensemble; soloist)'

This applies to all of the dialogs where 'Artist' appears except for 'Classical'.


Classical:
----------
The field order should more closely resemble 'music' so that it's less confusing (i.e so people know where the fields are) and because certain fields (e.g. Disc# / Track# are associated with the 'Album' field, and Composer is associated with Original Date).

Title; Date
Artist; Genre
Composer; Disc#, Track#
Conductor; Rating
Album; Orig Date
Album Artist; Lyricist
Comment

-->

Title; Rating
Artist; Genre
Conductor; Date
Composer; Original Date
Album; Disc#; Track#
Album Artist; Lyricist
Comment

Podcast:
--------
Currently has an 'Author' field instead of 'Artist' field.
  
Title; Date
Podcast; Genre
Author; Rating
 ; Track#

-->

Title; Date
Podcast; Genre
Artist; Rating
 ; Track #


Audiobook:
----------
I would suggest getting rid of the Conductor/Lyricist fields--they're completely irrelevant.


Video:
------
Series should be associated with Season# and Episode#. It would also be useful if the Rating would appear as the last item on the right (but not critical).

Title; Date
Series; Genre
Director; Season#; Episode#
Producer; Rating
Actor; Screenwriter

-->

Title; Date
Series; Season#; Episode#
Director; Genre
Producer; Rating
Screenwriter
Actor(s)

Ludek

2010-12-02 17:07

developer   ~0021558

Fixed in build 1330.

Note that for podcast I added the Artist, but the Author is also left, because Author of the podcast can be different from Artist (e.g. if it is a music bands podcast), so the layout is

Title; Date
Podcast; Genre
Author; Rating
Artist; Track #

rusty

2010-12-02 20:39

administrator   ~0021562

As discussed, it would probably be preferable to take the approach used in other apps which 'Artist' as the primary field (e.g. iTunes). As to the secondary field, in cases where the Podcast's author doesn't match the performing Artist, it would probably make most sense to use Album Artist (e.g. if a Podcast had a U2 song).

For the future, it would be good if we could use a common approach for both Podcasts and Audiobooks, that would allow both Author and Performer to be stored/communicated in a consistent manner.

Ludek

2010-12-02 20:46

developer   ~0021564

OK, podcast layout changed to

Title; Date
Podcast; Genre
Artist; Rating
Album Artist; Track #

rusty

2010-12-03 05:24

administrator   ~0021581

Verified 1330.