View Issue Details

IDProjectCategoryView StatusLast Update
0006571MediaMonkey (current)Now Playingpublic2010-12-09 00:24
Reporterrusty 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006571: Title summary should vary dependent on content Type
DescriptionMM should allow for 'Title Summaries' to be used in circumstances where it is necessary to have file data presented in a different fashion depending on the Type of file in question. Specifically such summaries would be useful for:
- The Now Playing list (1 line)
- The Player (1 line)
- Mixed content playlists (1 line)
- Art Browser (2 lines)

1) The UI for this can be in the 'Playback Rules' dialog:

One line summary, used in Now Playing, Player, and Playlists:
Format: ________________________ [>>]
Sample:

Two line summary, used in Album Browser:
Format: ________________________ [>>]
. . . . . . . . . . ________________________ [>>]
Sample:

2) The Summary column should be enabled by default in Now Playing for all content Types (instead of Title column). i.e. only #, Summary (dislayed as Now Playing), length.

3) The Summary column header should appear in Now Playing as 'Now Playing' (rather than as 'Summary'). 'Title' should appear as 'Title'.

4) The following default summary formats should be used

Music: Artist (if it exists) - Title
Classical Music: Composer (if it exists, else Artist (if it exists)) - Title
Video: Series (if it exists) - Title
Music Video: Artist (if it exists) - Title
TV: Series (if it exists) - Title
Podcast: Podcast (if it exists) - Episode
Audiobook: Album (if it exists) - Title
Additional InformationNote: this has been implemented partially.
TagsNo tags attached.
Fixed in build1331

Relationships

related to 0006579 closedpetr UI Simplification: Remove 'Views' from Collections Options 
related to 0006572 closedLudek Per Type Playback Rules for Auto-DJ & Track Addition 
child of 0006575 closedLudek Different content Types should have different Properties window layouts 

Activities

Ludek

2010-10-23 00:09

developer   ~0020922

Last edited: 2010-10-23 00:13

View 3 revisions

Rusty, I partially implmented this in build 1318.

But I have several questions:

1) I added the one line summary filled by the default masks specified in 4), it looks like this:

Summary (Used in Now Playing, Player, etc.):
_$if(<Artist>,<Artist> - ,)<Title>______ [>>]
Sample: Bob Dylan - I want you

Question a) Is there really need also for the two lines summary, to simplify I would just use the one line summary in the Art Browser as well?
Question b) If the answer from a) is YES then what should be the default values in this case?

rusty

2010-10-26 21:24

administrator   ~0020994

a) I'll define the needs, and then you can tell me whether you think there's a better way:
i) There's a need to display 1 line of text in reference to individual files (e.g. Now Playing, in the Player)
ii) There is a need to display 2 lines of text in reference to individual files (e.g. individual Videos in the Art Browser, Art View or Art + Details view e.g.
 Battlestar Galactica
 Season 1 Episode 2 - The Hill
)

OR 2 lines of text in reference to Stacked files (e.g. Albums consisting of 1+ tracks in the Art Browser, Art View, or Art + Details view e.g.
Pink Floyd
The Final Cut
).

The tricky part is that it would be preferable if the user wouldn't have to change the Summary format in response to changes to Stacking (e.g. if the user decides to Stack files by Series for the TV Collection, then it should just display as: Battlestar Galactica ).

Given the above, do you have a better idea?

I'm wondering if perhaps something like the following might work better:
Summary format for individual files:
Group: _<Genre> - <Series>______ [>>]
Title: ________________________ [>>]
Sample: [shows how it would display as one line or as two lines]

Summary format for stacked files:
Line 1: ________________________ [>>]
Line 2: ________________________ [>>]
Sample:

Hopefully you have a better idea...this isn't too elegant.


Two-line Summary: Used in

Ludek

2010-10-27 12:59

developer   ~0021013

Last edited: 2010-10-27 13:57

View 4 revisions

What about the following:

Summary format for [individual files^]:
Line 1 (Now Playing, Player): __<track#:2> - <title>__________________ [>>]
Line 2 (Album Art views): __<Artist> - <Album>______ [>>]
Sample: 01 - Shine On you crazy diamond (part 1)
Pink Floyd - Wish You Were Here


... after switching the checkbox there would be

Summary format for [grouped files^]:
Line 1 (Album Art views): __<Artist>__________________ [>>]
Line 2 (Album Art views): __<Album>______ [>>]
Sample: Pink Floyd
Wish You Were Here

rusty

2010-10-27 15:18

administrator   ~0021015

The problem with both of our proposals is that:
1) user might rather display the following in Now Playing:
<Artist> - <Title> (can't be done with your proposal)
<Title> (<Artist>) (can't be done with my proposal)
2) any change in 'stacking' logic requires a second change to the stacking summary format. not a huge issue because atm, the only stacking options are enabled/disabled, but this may change for photos (e.g. stack by year, stack by month, etc.)

3) both proposals aren't totally clear

Here's a proposal that improves on 1) and 3). I'm thinking, though, that the section for 'Stacks of files' should probably be removed for reasons described in 2, and that Stacks should simply be titled based on the Stack attributes (e.g. if the Stack is based on Album, then show the Album and the associated Album field (e.g. Album Artist), if it's based on Podcast, show Podcast and Podcast Artist (not Artist, but Podcast Artist). If it's based on another attribute (e.g. year), then show that other attribute.

Summary Format:
 . Individual files:
 . . Player: . _____________________ [<<]
 . . Art View: ____________________ [<<]
 . . . . . . . ____________________ [<<]

 . Stacks of files:
 . . Art View: ____________________ [<<]
 . . . . . . . _____________________ [<<]

rusty

2010-10-27 19:07

administrator   ~0021026

Note: In discussion re. 6579, we agreed that there shouldn't be configuration for Stacks. See excepts below:

Ok, so it seems that we are all in agreement now.

Just a note re. stacking - Rusty might be right that instead of a special configuration, the stacking behavior might rather depend on the selected Collection/View. For example, I can imagine that TV root node would show all non-stacked TV Shows, while TV\Series node would show them stacked by Series. So, since this implementation seems to be easier to do, we probably should go this way - i.e. no configuration, and try to figure out some useful grouping/stacking defaults for misc. content/view combinations.

Jiri

On Wed, Oct 27, 2010 at 09:14, Russell Samuels <rs@mediamonkey.com> wrote:
Agreed -- it's unclear how this will evolve, so we should go with the simplest approach that meets the different needs of each of the nodes (incl. Collections, Playlists, My Computer nodes, etc.)

Note: if you choose something similar to 3.x, please do a lot of testing on the columns--I'm finding columns are moving/changing position in MM4 (in relation to the 2 special columns in AA views).

-Rusty


On Wed, Oct 27, 2010 at 12:05 PM, Jiri Hajek <jh@mediamonkey.com> wrote:

Well, the original suggestion was that these should be 3 distinct columns (no matter how they are related), so that they can be easily configured. Note that, regardless how we decide this particular issue, we will have >1 version of some columns - e.g. we will have both Album and Podcast columns, even though they will refer to the same content - as described elsewhere in the Mantis issue.

Anyway, back to this one: You are right that having a separate configuration for AA+Details view might complicate some things. So, the alternative I was suggesting was, that we could leave it as is in MM 3.x (i.e. have the same columns as in Details view), but we have to solve the issue of showing the correct 1st two columns. It certainly _can_ be based on Type of collection, it's just that we are not sure how reliable this will be - e.g. in case user configures the Collection as Type in [Music; Video], it isn't clear which column to automatically choose.

That said, this doesn't seem to be a critical issue and maybe we will even change our mind in the future re. the best implementation, so for now I wouldn't mind choosing the easiest implementation (which would probably mean something very similar to MM 3.x) and see how well it works.

Jiri


On Wed, Oct 27, 2010 at 08:47, Petr <petr@mediamonkey.com> wrote:

Album/Artist, Series/Title or Podcast/Artist is same column but
with changed title based on collection type, isn't it ? This column
(together with Artwork column) should be always visible in AA+Details
as is now. Question is why we need to define columns in AA+Details
independent on Details view (and Art Browser).

jiri

2010-11-03 17:54

administrator   ~0021157

So, given all that has been discussed, do we all agree that after all the original spec (as it appears in Description of this) issue is that best solution? For me it seems to be, it's reasonably simple and easy to understand. I.e., all the stacking issues would be discarded, at least for now.

Ludek

2010-11-03 20:02

developer   ~0021160

Assigning to Rusty for the conclusion and for the specification of the default values for the two line summary.

rusty

2010-11-04 05:03

administrator   ~0021167

In answer to Jiri: yes, we mostly agree that the original spec is the solution, BUT, stacking issues are not discarded. They are just not configurable from this UI--instead they are hardcoded. i.e.
-When user enables 'Artist/Album' column, the stacking works as it does today.
-When user enables 'Series' column, the stacking works similarly, but for the Series field.

As far as the UI for the Summary section of Playback Rules, I would just suggest a couple of text changes to simplify:
Summary format for individual files:
 . . Player: _____________________[<<]
 . . Sample:

 . . Art View: ____________________ [<<]
 . . . . . . . ____________________ [<<]
 . . . Sample:


Defaults for the two line summaries can be:
Music: Album, Album Artist
Classical Music: Album, Album Artist
Video: Series (if it exists) otherwise, Title
Music Video: Title, Artist
TV: Series (if it exists) otherwise, Title
Podcast: Podcast (if it exists), Artist
Audiobook: Album (if it exists), Album Artist

Ludek

2010-11-05 23:28

developer   ~0021209

Last edited: 2010-11-05 23:35

View 4 revisions

Added the configs and the default values in build 1323.

Assigning to Petr in order to apply the configs to Player/Album Art Views.

petr

2010-11-08 17:06

developer   ~0021248

Implemented in 1324

stephen_platt

2010-11-12 00:51

developer   ~0021323

After upgrading from MM3, no collection has the title summary defined. (For all collections it is blank).

petr

2010-11-12 18:48

developer   ~0021326

I'm unable to reproduce

stephen_platt

2010-11-18 23:28

developer   ~0021393

verified 1326

rusty

2010-12-02 15:59

administrator   ~0021553

I just did a clean install of MM4, and Playback Rules and Titles are all missing! Please test on a clean install.

petr

2010-12-02 17:34

developer   ~0021559

Fixed in 1330

rusty

2010-12-03 05:29

administrator   ~0021583

Tested 1330 (clean install on Win7) and it's still not resolved (i.e. there's no default configuratings for playback rules).

petr

2010-12-03 11:24

developer   ~0021587

Fixed in 1331

rusty

2010-12-05 06:15

administrator   ~0021600

Last edited: 2010-12-05 06:16

View 2 revisions

Default configs work in 1331. Leaving 'resolved' for Peke to verify all functionality.

peke

2010-12-09 00:24

developer   ~0021693

Hope Got them all

Verified 1331 and re-verified 1332