View Issue Details

IDProjectCategoryView StatusLast Update
0011671MediaMonkey (current)Skinspublic2014-11-11 22:33
ReporterLudek 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1 
Target Version4.1.2Fixed in Version4.1.2 
Summary0011671: Glided skin is no longer included within installer and also is not available to download
DescriptionSome users are asking why Glided was removed from the installer 0011667:0039089

What was the reason to remove it in 0010769 ?
If there is a reason then we should at least add Glided to Addons so that it can be downloaded from mediamonkey.com (http://www.mediamonkey.com/addons/browse/appearance/skins/)
TagsNo tags attached.
Fixed in build1706

Relationships

related to 0011667 resolvedLudek Skinned Label control is visualy same when disabled 
child of 0010769 resolvedpetr Replace Glided skin with MetroMonkey 
child of 0010823 closedLudek Non-skinned mode doesn't look right (regression in 4.1.0.1617) 

Activities

rusty

2014-01-05 02:31

administrator   ~0039100

Perhaps we can package it as an addon (v1.0) to be posted to the addons site.

Ludek

2014-01-06 13:22

developer   ~0039109

Last edited: 2014-01-06 13:25

View 4 revisions

My understanding from Zvezdan's note here 0010769:0039090 is that some of his scripts may rely on the "Glided" skin.

This could be a reason to still bundle this skin with MM, but if you see another reason why to not bundle this skin then let's post it as addon.

rusty

2014-01-07 17:58

administrator   ~0039118

Last edited: 2014-01-07 17:58

View 2 revisions

The problem is that the skin's icons have some artifacts in MM4.1 (and I suspect that there are probably some missing icons as well). So I suggest creating an MMIP file which I can then post; and if we or one of our users updates it, we can re-include it in the future.

rusty

2014-01-07 17:58

administrator  

glided_icon_artifacts.jpg (100,444 bytes)
glided_icon_artifacts.jpg (100,444 bytes)

Ludek

2014-01-07 18:08

developer   ~0039119

Last edited: 2014-01-07 18:10

View 2 revisions

I see, it is child of 0010823 where it was caused by fix of 0000564 (tech: by adding {$R 'Win8DPI.RES'} to the DPR file)

So lets wait until the skin is updated.

zvezdan

2014-01-15 23:57

updater   ~0039250

Ludek, no, you misunderstood my concerns. My scripts don't rely on Glided skin, but I mentioned it just as an example. If my scripts find, in another example, PlayerSkinNameNew3=Vitreous.msz in MM ini file (which means that Vitreous skin is active) then they will try to load my Vitreous.css file. I have several CSS files that are related to several skins and they share the same filenames.

It was a problem with Metro M (1.4.4) skin because it had the version number in its filename, but it seems that petr already fixed that.

However, unrelated to my scripts, I like the Glided skin and even some users are asking me in e-mail could I send them that skin because they cannot find it with the current version of the program.

Ludek

2014-02-13 16:54

developer   ~0039579

Resolved as 'no change required', creator of the Glided skin can publish it via Addons section once the skin is fixed.

rusty

2014-02-13 18:39

administrator   ~0039590

Re-opening. We should post it, or update it and then post it (since Morten is no longer using a Windows machine).

Checking with Stephen if he can take care of this.

stephen_platt

2014-02-13 19:51

developer   ~0039594

Last edited: 2014-02-13 19:52

View 2 revisions

This is a bug in MM. Glided doesn't have any custom icons, it just uses the default MM icons.

Same problem affects all other skins that don't use custom icons.

(see http://www.mediamonkey.com/forum/viewtopic.php?f=9&t=50934&start=60#p383300 )

Ludek

2014-05-26 23:09

developer   ~0040243

Fixed the issue with collection icon artifacts in build 4.1.2.1706
Now, the icons from Virteous are used as default icons (if not defined by skinner)


Assigned to Peke to publish the Glided skin to our Addons site.

peke

2014-11-11 00:46

developer   ~0040951

Skin Uploaded to FTP under Bug can you please check if it can be released.

rusty

2014-11-11 05:39

administrator   ~0040958

Looks good. Just the name and description should be updated:
Name: Glided Skin
Description: Skin that was bundled until v4.0.7

peke

2014-11-11 22:33

developer   ~0040962

Corrected String and Skin is uploaded to Addons Site

http://www.mediamonkey.com/addons/browse/item/glided-skin/