View Issue Details

IDProjectCategoryView StatusLast Update
0010769MediaMonkey (current)Otherpublic2014-01-17 15:06
Reporterrusty Assigned To 
PriorityimmediateSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1 
Target Version4.1Fixed in Version4.1 
Summary0010769: Replace Glided skin with MetroMonkey
DescriptionWe should switch the Glided skin with the new MetroMonkey slim skin.

Before we make the switch, we need an update to the skin that resolves performance issues (Currently, some skin redraws are so slow that they're visible. You can see this in the metro monkey skin by selecting a device, and then switching between tabs in the device configuration screen).
TagsNo tags attached.
Fixed in build1688

Relationships

parent of 0011671 resolvedpeke Glided skin is no longer included within installer and also is not available to download 

Activities

petr

2013-04-24 18:52

developer   ~0035759

Fixed in 1635

petr

2013-04-24 19:16

developer   ~0035760

Leaving open till performance issues are fixed

rusty

2013-04-26 04:06

administrator   ~0035783

Raised to 'immediate' for inclusion in the next build, since performance issues have been resolved.

stephen_platt

2013-05-05 22:18

developer   ~0035922

verified 1636

rusty

2013-05-22 13:17

administrator   ~0036136

Last edited: 2013-05-26 18:14

View 2 revisions

We should include version 1.4.4 of the skin.

Note: the skin name should display as 'Metro M (1.4.4)' (instead of Metro_M_1,4,4).

petr

2013-05-26 21:48

developer   ~0036189

Fixed in 1639

peke

2013-06-09 22:57

developer   ~0036395

Verified 1642

zvezdan

2014-01-03 16:22

updater   ~0039090

I am sorry for re-opening this issue, but I just want to say that it is not very good idea to add the skin version to its name, especially not to its file name.

I have several scripts that have css styles used with ActiveX controls for several popular skins. My scripts have detection which skin is currently active by reading the PlayerSkinNameNew3 key from the [Appearance] section in the .ini file. As you know, that key has stored the skin's file name. Because of that my .css files are named after the skins filenames, e.g. if my script finds PlayerSkinNameNew3=Glided.msz in .ini file then it will load my Glided.css file.

Currently, I have added Metro M (1.4.4).css file for your Metro skin, but if you decide to update that skin and if you modify the skin's file name because of the changed version, then my scripts will not display ActiveX controls correctly with that skin anymore.

petr

2014-01-03 16:54

developer   ~0039091

I agree to add skin without version#.

petr

2014-01-03 17:23

developer   ~0039092

I've removed version number from name.

Ludek

2014-01-17 14:39

developer   ~0039284

Last edited: 2014-01-17 14:58

View 8 revisions

There is a serious regression related to renaming of the skin, build 1686 starts without skin and trying to open device config throws AV because of the skin issue.

Confirmed myself and can be seen in several ELFs from 1686, is also reported here: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=75128&p=381772#p381748

Edit: To reproduce: just install build 1686 to separate folder

petr

2014-01-17 15:06

developer   ~0039285

Fixed in 1688