View Issue Details

IDProjectCategoryView StatusLast Update
0000564MediaMonkey (current)Otherpublic2013-05-14 17:37
Reporterrusty Assigned To 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version4.0.7 
Target Version4.1Fixed in Version4.1 
Summary0000564: Display Problems with non-standard Windows font size
DescriptionIf the user sets font size to anything besides normal, then:
1) the fonts don't display uniformly in size
2) some of the controls don't accomodate the change in size.

Suggested future improvements from Jiri:
- Try to follow the setting of 'Large fonts' when possible.
- Save window positions and column widths relatively to DPI and screen size, thus allowing better restore when these system parameters are changed.
Additional InformationSource: Bug #546
TagsNo tags attached.
Fixed in build1637

Relationships

parent of 0005871 closedpetr MediaMonkey (current) Wrong files are selected when Windows and MM fonts are enlarged 
parent of 0006363 closedLudek MediaMonkey (current) Fields cut off on high DPI screens 
parent of 0010823 closedLudek MediaMonkey (current) Non-skinned mode doesn't look right (regression in 4.1.0.1617) 
has duplicate 0004076 closedpetr MediaMonkey (current) Font sizes are inconsistent and controls don't match up with font sizes 
has duplicate 0006372 closedpetr MediaMonkey (current) Font size changed by system DPI doesn't work correctly for some controls 
related to 0007408 closedpetr MediaMonkey (current) Some dialogs are cut off when font size is increased 
related to 0006195 closedpetr MediaMonkey (current) Tracklist fonts increase in size as font size is set below 11 
related to 0002911 assignedpetr MediaMonkey (current) Non 96 DPI setting can cause some dialog boxes from scripts to be corrupted 
related to 0007845 closedpetr MediaMonkey (current) Non-default DPI/font size fails to show scrollbar in Filelistings 
related to 0010300 closedpetr MediaMonkey (current) Tooltips don't display correctly with increased font size 

Activities

rusty

2012-12-06 16:46

administrator   ~0033704

Tested with MM 4.0.7 and Windows 8 @150dpi, and the above issues seem to be resolved. The only items that I notice are:
- Text is blurry
- Tabs have graphic artifacts
- Numerous icons are blurry

Assigning to Jiri for triage.

petr

2012-12-20 16:46

developer   ~0034063

I've tried latest 4.1 build in windows 8 with 150% DPI and here's my results:

- text is blurry:
 i agree, but it's not just MM problem. Delphi have same, blurry texts and icons (looks like system simply resize them and use anti-alias to remove edges). Will try to investigate more on holidays.

- tabs:
 tabs look fine here

petr

2013-01-02 18:22

developer   ~0034237

Fixed in 1617

peke

2013-01-23 00:53

developer   ~0034619

Verified 1622 Win 7

peke

2013-02-20 23:03

developer   ~0035019

Closing and re verified 1624

No additional reports.

Ludek

2013-05-10 20:39

developer   ~0036033

Last edited: 2013-05-10 20:42

View 3 revisions

The fix was reverted for skinless build, because it caused ugly artifacts on skinless build 0010823

peke

2013-05-13 21:18

developer   ~0036067

Rusty can you confirm that no regressions are introduced.

rusty

2013-05-14 17:37

administrator   ~0036080

Verified 1637 (i.e. it works as expected in skinned mode, and has a limitation of slightly blurry text in the tabs in unskinned mode).