View Issue Details

IDProjectCategoryView StatusLast Update
0011667MediaMonkey (current)Framework: Scripts/Extensionspublic2014-01-03 08:27
Reporterzvezdan Assigned To 
PrioritynoneSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in Version4.1 
Summary0011667: Skinned Label control is visualy same when disabled
DescriptionI don't know if built-in Label controls have the same problem and if I should report this to Scripts category or maybe in the Skins category.

If I set Label.Common.Enabled = False, the foreground color stays same with all native skins (Glided, Vitreous...). Metro skin has a black disabled foreground color which is also wrong since it is invisible on the form's black background. I tried also bunch of third-party skins and only Eclipse, MM-Ultimate and Zekton display disabled state of Label controls correctly.

I understand that the skins authors are not so methodical with such thing, but I expect that at least 3 or 4 built-in skins have that implemented correctly.

By the way, the non-skinned version doesn't have such problem.
TagsNo tags attached.
Fixed in build1670

Relationships

related to 0011671 resolvedpeke Glided skin is no longer included within installer and also is not available to download 

Activities

Ludek

2014-01-01 17:14

developer   ~0039076

Last edited: 2014-01-01 17:14

View 2 revisions

This is skin issue and have been already fixed for default skins (Metro, Virteous, Pulse) in recent 4.1 builds

zvezdan

2014-01-03 08:27

updater   ~0039089

Sorry, I tested it with 1662 so I though it is still unresolved because I remember this problem since early v3 beta.

However, there are still some issues:
- Pulse has red disabled foreground color which is totally in contrast with all other its colors (it is recommended that Label colors be the same as Check boxes and Radio buttons);
- Metro has disabled colors that are not too much different than enabled colors, but that decision is up to its author.

By the way, what happened to the Glided skin? Why don't you include it with the program anymore? It is very nice skin that I am used to it.