View Issue Details

IDProjectCategoryView StatusLast Update
0007414MediaMonkey 4Synchronizationpublic2011-05-16 00:25
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0007414: Synchronization gets stuck on certain files
DescriptionI'm not sure why this is the case, but synchronization seems to just get stuck on certain files.

i.e. synced ~ 6500 files, but then tracks in a particular directory just can't sync.

Note:
-Auto-conversion was not enabled
-Files were synced using Mass USB Plugin, with save AA to Tag enabled
-Files were just being synced to a portable drive
-Upon trying to sync again, sync would get stuck at file1 (the problematic file--see debug log)
-Upon deleting the problematic files synchronization worked as expected.

Log and problem files posted to server.
TagsNo tags attached.
Fixed in build1351

Relationships

related to 0007070 closedLudek Adapt Album Art Tagging Dialogs to better support Video 
related to 0007431 closedLudek Too large images cannot be stored into tag 

Activities

rusty

2011-02-20 19:34

administrator   ~0023238

Note: when 'Save AA to Tag' is disabled, synchronization proceeds normally. Re-assigning to Ludek.

Ludek

2011-02-22 19:33

developer   ~0023319

Last edited: 2011-02-22 19:45

View 2 revisions

It freezes in ID3Lib when calling ID3Tag_UpdateByTagType, probably the images are too large (>4MB) to be written to ID3 tag. The same freeze appears when user tries to add the large JPG image to tag via Properties->Artwork.

By testing I found that 1MB large JPEG takes ~ 20 seconds when writing to ID3 tag.
4MB large JPEG seems to be endless.

Ludek

2011-02-22 20:05

developer   ~0023321

Last edited: 2011-02-22 20:08

View 2 revisions

I resolved this by auto-resizing large images to 256x256 px JPEG when writing to file tag during device sync.

Fixed in build 1351.

Note that you can still notice a 7 second delay, but this is because of the conversion of the 6 hi-res JPEGs to 256x256.

Ludek

2011-02-23 13:34

developer   ~0023343

Reverted the changes, because the original problem of slow tagging is now resolved by fixing ID3Lib directly (0007431).

So all should work fast now without a need to resize large images.

stephen_platt

2011-05-16 00:25

developer   ~0025291

verified 1375