View Issue Details

IDProjectCategoryView StatusLast Update
0006654MediaMonkey (current)Main Panelpublic2015-03-05 17:37
Reporterstephen_platt 
PriorityimmediateSeveritycrashReproducibilityhave not tried
Status closedResolutionnot fixable 
Product Version3.2.2 
Target VersionFixed in Version 
Summary0006654: Zumocast crashes MM
DescriptionWhen Zumocast is installed on a user's PC ( http://www.zumocast.com/ , a media streaming application for portable devices) it crashes MediaMonkey about 5 minutes after MM was opened. There were 3 tickets opened regarding this problem, and a thread in the forum about it.
Steps To ReproduceI haven't installed Zumocast myself, but I assume you just install Zumocast and run MM. A portable device might need to be plugged in for the crash to occur, though I'm not sure of that.
Additional Informationhttp://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=10120&departmentid=2&ticketstatusid=4
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=9918&highlight=--+Mixed+--&ticketsearchid=2292
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=9405&offset=20
http://mediamonkey.com/forum/viewtopic.php?f=7&t=53415
TagsNo tags attached.
Fixed in build

Relationships

related to 0006223 closedpeke Corupted Quicktime-related crashes on certain systems 
related to 0007509 closedpeke ZumoCast: Zumo Drive Crashes MM 

Activities

jiri

2010-11-08 17:12

administrator   ~0021250

That would probably mean it's related to d_wmdm plug-in?

Peke, could you try to reproduce please?

rusty

2010-11-09 21:38

administrator   ~0021282

Last edited: 2010-11-10 02:03

View 2 revisions

I can't reproduce this on my system, but I did notice that Zumocast uses the iTunes scripting API, and tends to open up iTunes after some period of time. Perhaps it's this action which triggers the crash (i.e. bug 0006223).

Edit: Peke tested as well and couldn't replicate the bug.

rusty

2010-11-10 22:51

administrator   ~0021301

Zumocast suggested that it may be a result of a DLL used to add items to the context menu in the Windows shell. They suggested testing this out by using the following on a system with the problem to see if it helps:

regsvr32.exe /u "C:\Program Files\Zecter\ZumoCast\ShellExt.dll"

jiri

2010-11-16 08:33

administrator   ~0021359

Resolving for now, please reopen in case we find out that there's something we can do about it in MM.

rusty

2010-11-16 14:08

administrator   ~0021360

Last edited: 2010-11-16 14:16

View 2 revisions

Note: according to Zumocast, the suggested workaround solves the problem--i.e. it's somehow related to shell integration.

I've updated the KB at http://www.mediamonkey.com/support/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=33

peke

2010-11-22 18:02

developer   ~0021411

I was able to replicate the issue by manually register Zumocast Shell extension
using:
CMD (run as admin) -> regsvr32.exe "C:\Program Files (x86)\Zecter\ZumoCast\ShellExt.dll"

After restart MM crashed.

Than I followed KB article and use regsvr32.exe /u "C:\Program Files (x86)\Zecter\ZumoCast\ShellExt.dll"

Which resolved problem.