View Issue Details

IDProjectCategoryView StatusLast Update
0004609MediaMonkey 4Properties/Auto-Toolspublic2009-02-21 17:10
Reporterrusty Assigned To 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Fixed in Version3.1 
Summary0004609: Allow date queries based on time relative to the present
DescriptionIt should be possible to create autoplaylists in such a manner that the user doesn't always have to reset the playlist when the calendar year changes to e.g. 2009.

For example: A playlist of 2000 to 2007 needs to be reset to 2000 to 2008 on Jan. 1 2008.

This should be supported in 2 ways:
Year x to current
Current year and previous x years

Possible UI:
1)
Condition: between
From: x
To: Present ^ (i.e. 'Present' is a valid value that represents the current year)

And

2)
Condition: years ago
From: x
To: Present (note: this value cannot be set--it just appears for clarity)

This isn't the most elegant UI. A nicer way of implementing this would be to enter queries in a manner similar to WMP, however, that's probably too much at this point.
Steps To ReproduceReported at:
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=596
Tagsdoc_help
Fixed in build1203

Relationships

related to 0005024 feedbackrusty Advanced queries based on dates relative to the present 

Activities

Ludek

2008-10-14 00:21

developer   ~0014747

I think that the proposal 1) is elegant, i.e.

Property: Date
Condition: between
From: 2005^
To: Present^

should be acceptable. There should be several use-cases in the dropdown (like '2005','Present','1.6.2005','05/06/08', etc.) so that user could see what he can input as acceptable value.

Ludek

2008-10-14 18:12

developer   ~0014749

Last edited: 2008-10-14 18:13

I decided to not situate the use cases to a dropdown, but better way seems to be to fill in some default values for integer and date fields similar like iTunes has.

i.e. I added default values for fields like
BPM = 60
Bitrate > 128
Play Counter = 0
Date < Present
Date > 2000
Date between (1.1.2000;Present)
etc.

Try to review the default values, I think it works fine and prompts users to input right/acceptable values.

Added in build 1189.

Bex

2008-12-10 01:21

updater   ~0015573

Last edited: 2008-12-10 03:52

Looks great. Some minor things though:
1)Default BPM should be 120.
2)To avoid confusion and typing errors, the default date value should be in the format MM displays it in the date field. (From the regional settings.)
3)Also, when I search for "Date between (1.1.2000;Present)", tracks with only year 2000 is not found. Not a big thing but if I search from 1 jan 2000, I would expect that track with only year 2000 is returned.

4) I miss a PresentYear (if introduced perhaps rename Present to PresentDate).
LastYear would also be nice but even better if you could add "modifiers" after PresentYear/PresentDate. I.e -X Year,Month,Week,Day
Example: (Date='2008-12-10')
PresentYear -2 Year = 2006
PresentDate -2 Month = 2006-10-10

That would also take care of point 2 above (Years ago condition).


5) It would also be nice to be able to search specific dates in the other date fields that exists: (It has been requested.)
 - Added
 - Last Played
 - Timestamp (shouldn't this be renamed to File Modified? Both here and in the main window.)
I also miss Track Modified in the search as well as in the main window.

rusty

2008-12-10 03:54

administrator   ~0015575

I annotated Bex's comment (15573) with numbers. Items 1, 2, 3 should be resolved as 'immediate' for 3.1.

Items 4 and 5, should be tracked as separate issues for the future.

Ludek

2008-12-11 10:48

developer   ~0015595

Last edited: 2008-12-11 10:49

1,2,3: fixed in build 1203.

4,5: entered 0005024

stephen_platt

2009-02-21 17:10

developer   ~0016870

verified 1224