View Issue Details

IDProjectCategoryView StatusLast Update
0003252MediaMonkey 4Otherpublic2008-12-31 05:39
Reporterrusty Assigned To 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Fixed in Version3.1 
Summary0003252: Podcasts: Import / Export OPML
DescriptionUsers have requested the ability to import a local OPML file.

Essentially add a "Browse" button to the "Add Directory" dialog. This would make switching from other podcatchers to MM much simpler by being able to use the OPML files that most podcatchers can generate.

It would also be good (though less critical) to be able to generate an OPML file from MM so that user can back up or share with other users their favorite podcasts.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?t=19001

http://www.mediamonkey.com/forum/viewtopic.php?t=24426
Tagsdoc_help
Fixed in build1205

Relationships

has duplicate 0004393 closedLudek Allow import OPML dirs from a local drive 
related to 0005185 closedLudek Installation Not Creating Export M3U and Export OPML Scripts (regression) 

Activities

rusty

2008-02-19 14:37

administrator   ~0013183

Note: in terms of importing OPML, the way this should work is that scanning folders should scan for opml files (i.e. no new command is required). The OPML directory should just appear in the 'Podcast Directories' folder.

In terms of exporting OPML, I would suggest that the simplest approach would be to integrate this into the Export All Playlists script. i.e.

Name: Export All Playlists / Subscribed Podcasts...
Dialog: Select where to export all M3U files --> Choose where to export m3u / opml files

Ludek

2008-03-20 10:08

developer   ~0013403

As reported here:
http://www.mediamonkey.com/forum/viewtopic.php?t=27403

Importing OPML dir from a local drive is often requested therefore I would add importing prior to exporting. i.e. 3.0 prior to 3.1

Ludek

2008-03-20 15:23

developer   ~0013408

Last edited: 2008-03-20 21:08

Added ability to import also an OPML file from a local drive

+ added dialog with 'Browse' button

+ added new Edit->Podcasts->Add Directory menu item.

All in build 1145.

Ludek

2008-03-20 21:08

developer   ~0013429

Fixed in build 1145.

rusty

2008-03-21 13:26

administrator   ~0013440

Last edited: 2008-04-01 18:44

One small suggestion for importing OPML directory: would it make sense to add OPML as a supported file type for File > Add Rescan Tracks... ?

Ludek

2008-07-30 22:50

developer   ~0014436

OPML Export implemented in build 1185.

Created separated script (ExportOPML.vbs) for podcast exporting:
Tools -> Scripts -> Export subscribed Podcasts...

Try to review and re-assing to me for possible wording modifications or possible improvements.

rusty

2008-12-01 21:13

administrator   ~0015280

The script doesn't work. It looks like it hasn't been added to the build/installer.

petr

2008-12-01 21:34

developer   ~0015281

Fixed build batch. Will be in 1198.

Owyn

2008-12-06 01:10

updater   ~0015440

Tried to test function in 1201.
ExportOPML.vbs in MM3 folder, but, not shown in Scripts menu.

Owyn

2008-12-06 01:19

updater   ~0015441

Just checked Scripts.ini.
No entry for ExportOPML.

Owyn

2008-12-06 03:37

updater   ~0015442

Added following section to Scripts.ini and tested export and import of exported opml file.
Looks good. Particularly like the order by Podcast Name.

[ExportOPML]
FileName=ExportOPML.vbs
ProcName=ExportOPML
Order=40
DisplayName=Export all Podcasts...
Description=Exports all Podcast Subscriptions to .m3u
Language=VBScript
ScriptType=0

Owyn

2008-12-06 03:39

updater   ~0015443

Oops. You can see where I copied the section from.

Description=Exports all Podcast Subscriptions to .opml

Ludek

2008-12-06 11:55

developer   ~0015446

Tested 1201 and the following is there in the Scripts.ini

[ExportOPML]
FileName=ExportOPML.vbs
ProcName=ExportOPML
Order=50
DisplayName=Export subscribed Podcasts...
Description=Exports subscribed Podcasts to .opml file
Language=VBScript
ScriptType=0


Owyn

2008-12-06 12:13

updater   ~0015447

Hmmm. Maybe there was something about my Scripts.ini which prevented the new section from being added.
Will clean changes out and retest with next release.

rusty

2008-12-07 04:40

administrator   ~0015507

Verified 1201--seems to work in my environment.

Owyn

2008-12-27 00:19

updater   ~0015816

Found at least one reproducable case where the upgrade does not add the Export to OPML section to scripts.ini.

See:
http://www.mediamonkey.com/forum/viewtopic.php?f=2&t=24841&p=182142#p182142

Ludek

2008-12-27 15:18

developer   ~0015818

Note that ExportOPML hasn't any own installer, it has been only added to the set of default MM scripts. If someone change original scripts.ini then I suppose/expect ExportOPML to not be added to scripts.ini because it is not the default scripts.ini.

Bex

2008-12-27 15:50

updater   ~0015819

But shouldn't the OPML script get its scripts.ini section added to the scripts.ini file when upgrading, regardless if the user has custom scripts installed or not? Perhaps I'm misunderstanding something here?

Ludek

2008-12-28 17:53

developer   ~0015828

Yes, you are right. Added the scripts.ini update to the installer in build 1205.

Owyn

2008-12-31 01:09

updater   ~0015895

Verified in 1205