View Issue Details

IDProjectCategoryView StatusLast Update
0002997MediaMonkey 4Main Panel/Toolbars/Menuspublic2008-12-05 04:03
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.0 
Fixed in Version3.1 
Summary0002997: Album Art View: Image editing functions missing/inconsistent
DescriptionThe image editing functions that are available via the context menu should be the same as those in the Album Art window i.e.
     Image chooser
     --------------
     Enlarge Cover ---change to---> View full size
     --------------
     Edit Album Art properties (currently missing)
     Add image
     Paste (currently missing)
     Remove image (currently missing)

TagsNo tags attached.
Fixed in build1186

Relationships

related to 0001606 closedjiri Ability to Remove/Edit/or Apply existing Album Art for multiple tracks via Properties dialog 
related to 0003263 closedLudek Files to Edit: Inconsistent Album Art 
child of 0001612 closedpetr Album Art Views 

Activities

jiri

2007-04-13 13:50

administrator   ~0009001

Adding new commands is a little problematic - The album groups several tracks and they don't necessarily have all the same album art, etc.

So, I'd rather see Properties command there, so that Properties dialog appears for all the tracks of album and user can edit individual fields - including album art (when we implement this feature for >1 tracks in Properties dialog).

What I see as a bigger problem is that there are two pop-up menus - one shown on the cover and other on the rest of focused rectangle. I think that the second menu should be used everywhere, just a new Album Art submenu should be added where user could do related operations, like that View full size.

rusty

2007-04-13 21:03

administrator   ~0009010

I would propose that:
a) the the fact that multiple tracks with different album art are grouped under a single picture is a bug in its own right. i.e. If several tracks have different album art, they should not be grouped together with one Album Art picture in Album Art view. Otherwise it's impossible for users to know if their collection is properly tagged!
b) if issue a) is resolved then the issue in this bug can easily be fixed.

jiri

2007-04-17 14:49

administrator   ~0009033

I don't think that tracks should be grouped according to their associated album art, because:
1. It would make the solution more complex and slower (scanning of more tracks needed, etc.)
2. An example of confusing behaviour: User has 3 tracks of album tagged as jpg, 5 as gif, but both showing the same image - the result would be that MM would treat them as two separate albums, which would be possibly good for some users wanting to clean up their collection, but not for a general browsing.
3. For similar reasons (probably) WMP11 does it as MM currently does.

So, I'd leave it as it is, I just wonder whether users wouldn't like to have an option to locate albums with incosistent album art. For this purpose a script could be written, or maybe better, we could create a new subnode to Files to Edit - Inconsisten Album Art where such albums would be listed.

And one more issue - you didn't comment my previous note that there are currently two independent pop-up menus for AA view. I wrote it above as: What I see as a bigger problem is that there are two pop-up menus - one shown on the cover and other on the rest of focused rectangle. I think that the second menu should be used everywhere, just a new Album Art submenu should be added where user could do related operations, like that View full size.

rusty

2007-07-06 19:56

administrator   ~0009656

-Re. the proposal that Albums should be split in Album Art view if their art differs: OK, I can see why the current behavior might make more sense.

-Re. the originally raised issue that the Album Art functions are inconsistent, you originally indicated that you'd like to see the 'Properties' command since it will eventually apply to > 1 track. HOWEVER, this logic would mean that the Album Art Window commands should also be changed! i.e. if the user selects an Album in Album Art view, then they are selecting the collection of tracks in the Album. If that's the case, then it means that the commands in the Album Art window also need to apply to multiple tracks. In other words, both the Album Art Window AND the Album Art views _need_ to have a means of editing Album Art across multiple tracks (and this issue is now more urgent because of the fact that in the Album Art view, users expect to be able to edit Album Art for the set of selected tracks).

-Re. the idea of Files to Edit - Inconsisten Album Art, I like this. Once we decide on an approach for the above, I'll add that as a separate bug.

-Re. the fact that the context menu for the Album Art differs from the context-menu for the album art, I agree that we can combine this into a single menu for the album art view that would include of album art commands (TBD-depends on how we decide to resolve the need to edit Album Art for multiple tracks in AA view) when the focus is on the Album Art.

jiri

2007-07-11 12:21

administrator   ~0009683

Ok, so I guess the only thing needed now is to implement that edition of >1 track's album art in Properties dialog (covered in some other Mantis issue) and then the rest of this issue can be resolved (or even prior to this fix).

rusty

2007-07-12 20:43

administrator   ~0009698

Concretely, this boils down to the following changes:
In the Album Art Window:
1) Enlarge Cover ---change to---> View full size
2) When the user performs 'Edit Album Art Properties', the operation is performed on all selected tracks

In the Album Art View:
3) The context menu that appears for the tracks also appears for the Album Art, with the following changes:
   -Add Album Art should be added above 'Properties' context menu
   -Properties should take the user directly to the Album Art properties (instead of the first tab)


     Image chooser
     --------------
     Enlarge Cover ---change to---> View full size
     --------------
     Edit Album Art properties (currently missing)
     Add image
     Paste (currently missing)
     Remove image (currently missing)

petr

2008-09-22 22:54

developer   ~0014635

I've added missing items in popup menu, but without Remove item. It's because every track of the album can have different covers and with remove command i don't know what covers should be removed. Specified cover(s) can be removed from 'Edit Album Art Properties' which opens track properties for all tracks in selection.

stephen_platt

2008-12-05 04:03

developer   ~0015413

Verified 1199