View Issue Details

IDProjectCategoryView StatusLast Update
0020806MMW 5Main Panelpublic2024-05-29 15:46
Reporterlowlander Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.1 
Target Version5.1Fixed in Version5.1 
Summary0020806: List view doesn't tab into Rating when in-line editing
DescriptionWhen doing inline editing in the List View using Tab to go to the next column skips the Rating column. It does work in Properties.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?t=105983
TagsNo tags attached.
Fixed in build3026

Relationships

related to 0020844 closedlowlander In-line edit can fail in Playing node 
related to 0020887 closedLudek Inline Edit doesn't save 
related to 0020921 assignedrusty Ratings doesn't show full value/doesn't work when it exceeds column width 
related to 0020933 assignedmichal Issues with TAB order and Keyboard-only usage of MM 2024 
related to 0020962 assignedLudek Inline edit doesn't accept keystrokes 

Activities

Ludek

2024-04-03 10:14

developer   ~0074949

Last edited: 2024-04-03 10:15

This does not seem to be regression against previous 5.0.X versions..

But right, it worked in MM4..

Ludek

2024-04-05 11:59

developer   ~0074997

Almost complete code backed up to SVN, to be finished..

Ludek

2024-04-15 15:04

developer   ~0075118

Fixed in 3015

lowlander

2024-04-19 18:09

developer   ~0075166

Verified on 3015.

lowlander

2024-04-21 20:09

developer   ~0075187

Last edited: 2024-04-21 20:11

There seem to be some bugs with this fix:
1) Rating can become unhighlighted in highlighted file
2) Rating can become permanently shown (seen twice, don't know how to reproduce, it seems to happen in Playing set to List View).
3) Rating can not stick when set (this seems to happen when 1 happens)
image.png (19,990 bytes)   
image.png (19,990 bytes)   

lowlander

2024-04-22 14:33

developer   ~0075192

1) Jiri has it reproduced on the second attempt to set the Rating for a file. I somewhat see that too, but not 100% consistently.

lowlander

2024-04-22 15:09

developer   ~0075193

4) Rating can show as Playing, when file isn't.
image-2.png (51,959 bytes)   
image-2.png (51,959 bytes)   

lowlander

2024-04-22 16:29

developer   ~0075196

image-3.png (69,416 bytes)   
image-3.png (69,416 bytes)   

Ludek

2024-04-22 16:48

developer   ~0075197

Fixed in 3016

peke

2024-04-25 10:31

developer   ~0075264

Verified 3016

lowlander

2024-04-28 22:59

developer   ~0075308

When you Tab into the Rating field the Hotkey Alt+number doesn't have it's value stick.

Tried in List View in the Playing node. Playing window does show the Rating being set, till you navigate away from file:
1 Enter in-line edit in field left of Rating for a file without Rating value
2 Tab to Rating
3 Use Alt+5 to set 5 stars
4 Click any other file or hit Enter
--> Expect file to have 5 stars, instead is shows nothing set

Ludek

2024-05-03 12:48

developer   ~0075332

Fixed in 3019

lowlander

2024-05-03 15:25

developer   ~0075337

This works on 3019, but

1 Select field left of Rating
2 F2 (enter in-line editing)
3 Tab (into Rating)
4 Alt+5 (windows bing, rating set as expected)
--> File menu becomes highlighted
5 Enter
--> File menu opens

Ludek

2024-05-03 15:50

developer   ~0075339

I can't replicate, are you sure that Alt+5 activates the menu? What is the sequence of using 'Alt' and '5' keys?
There is a prevention and only 'Alt' or 'Alt+letter' activates the menu (working fine based on my tests)

Ludek

2024-05-03 19:59

developer   ~0075340

Last edited: 2024-05-03 20:04

ok, I see the difference when Alt+5 is used on numlock (no issue) versus special letters above..

=> Fixed in 3020 (the beep sound is still there, but main menu is no longer activated)

lowlander

2024-05-10 20:35

developer   ~0075392

Verified on 3020, but now Enter doesn't apply changes and exit edit state.

1 F2 on field to enter in-line edit
2 Enter
-> Nothing, expected exit of edit state.

michal

2024-05-11 11:05

developer   ~0075402

I cannot reproduce, tried clean 3020 and for me it works and Enter commits change and exits edit state.

Ludek

2024-05-14 16:35

developer   ~0075422

Last edited: 2024-05-14 16:36

Also for me Enter commits the changes just fine, I don't see a change in 3020 that could cause this..
Please re-test and if that's still an issue for you then please add more info and catch in screencast video..

lowlander

2024-05-28 14:31

developer   ~0075595

Last edited: 2024-05-28 14:35

It isn't consistent, but on 3025 I see:
1 Select Title field
2 F2 to enter inline editing
3 Tab to go to Rating
4 Alt+5
--> Rating set, Windows boing
5 Enter
--> Expect to be able to use up/down arrow to navigate to next/previous file in list, this isn't the case. Left/Right will eventually end up highlighting (but unopened) items in the Main Menu.

Screencast added (note that it shows success the first attempt (Danger), second file (I Need U) it fails)
image-5.png (14,194 bytes)   
image-5.png (14,194 bytes)   

Ludek

2024-05-28 15:33

developer   ~0075602

Fixed in 3026

lowlander

2024-05-28 21:18

developer   ~0075616

Verified on 3026.