View Issue Details

IDProjectCategoryView StatusLast Update
0020962MMW 5Main Panelpublic2024-06-10 15:28
Reporterlowlander Assigned To 
PriorityimmediateSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version5.1 
Target Version5.1Fixed in Version5.1 
Summary0020962: Inline edit doesn't accept keystrokes
DescriptionOn 3027 I experienced that inline edit didn't take keystrokes (ie. nothing changes when typing). Tried several fields, switching to different nodes also anew tab. Only restart resolved the issue. Only seen once.

This also affects the Media Tree, Search, and the title of the Playlist panel. However Properties is unaffected.
Additional InformationTicket 7183
https://www.mediamonkey.com/forum/viewtopic.php?t=106265
TagsNo tags attached.
Fixed in build3030

Relationships

related to 0020887 closedLudek Inline Edit doesn't save 
related to 0020806 closedLudek List view doesn't tab into Rating when in-line editing 
related to 0020960 closedpetr Crash on context menu (Regression) 

Activities

Ludek

2024-05-30 15:24

developer   ~0075638

Anyone can replicate this ? I haven't been successful to replicate so far.
I wonder what is the trigger as based on the log the document.activeElement is correct and should accept keystrokes without issue..

lowlander

2024-06-03 17:50

developer   ~0075703

MediaMonkeyEngine.exe using 7-10% CPU and 700+MB memory and increasing. Paused playback and CD Rip finished after discovery of failing to input, memory use continues to increase. So memory leak may be at play here. Once playback and CD Rip were finished, memory usage seemed to increase for a bit (after dropping at end of those tasks). Settling at ~5% CPU usage and 665MB memory usage.

lowlander

2024-06-03 21:24

developer   ~0075712

Last edited: 2024-06-03 21:28

AV 46150000 also observed

Edit Tags is not required for this. I also scoll wheel on mouse no longer working in Media Tree and Playing window, Filelisting still scrolls though.

High CPU/Memory isn't consistent when this occurs.

lowlander

2024-06-05 13:36

developer   ~0075773

User at https://www.mediamonkey.com/forum/viewtopic.php?t=106265 reports like ticket 7183 that Send To > Playlists won't allow editing of Playlist name.

Ludek

2024-06-07 15:01

developer   ~0075820

@LowLander :
Could you please re-test with 3029 whether the issue still happens?
And if yes then test whether it happens also with artwork lookup disabled, i.e. try to temporarily disable all checkboxes in Options > Library > Metadata Lookup > Background metadata lookup

lowlander

2024-06-07 16:37

developer   ~0075825

Last edited: 2024-06-07 16:38

Note that Artwork lookup was already disabled.

Users report of Send To > Playlist > New Playlist saw this on 3029. I'm wondering if multiple sub-menus levels in the context menu is a trigger. However trying the same right after a restart (with or without Lyrics lookup enabled) did not trigger this issue. So it seems a longer sequence of events is required to get to this state.

zvezdan

2024-06-07 19:14

updater   ~0075835

3029 - didn't accept keystrokes in inline edit in filelists, Auto-playlist editor (e.g. Title starts with ... couldn't type anything), title of Playlist editor (static), Preview panel / Allow edits, Search field... But Properties worked fine. It was once, after restart cannot replicate, but I have a log file when that happened, if you are interested.

zvezdan

2024-06-08 20:07

updater   ~0075843

Last edited: 2024-06-09 13:51

Actually, I could replicate it very often, even with cleared Portable folder. The video and log files in the 0020970 issue (https://www.ventismedia.com/mantis/view.php?id=20970#c75841).

What is interesting, the Tab key works fine, but not Alt+F / Alt+V ... for the main menu.

I am wondering if this issue is related to 0020514, since they similar symptoms (Search box inaccessible, mouse wheel not working).

lowlander

2024-06-09 20:05

developer   ~0075848

Just seen where inline edit of Original Date worked on a file, then editing next file it failed and MM stopped taking key entries in the main window.

More users are saying they're experiencing this bug.

Ludek

2024-06-10 13:57

developer   ~0075860

Last edited: 2024-06-10 13:58

I have no idea how to get to this state and nobody from the devs can replicate..
If you could catch some steps to reproduce, screencast and debug log it would be helpful to find a clue..

zvezdan

2024-06-10 13:59

updater   ~0075861

@Ludek, who are you asking? I posted video and log file.

Ludek

2024-06-10 14:06

developer   ~0075862

Last edited: 2024-06-10 14:18

@Zvezdan: Good idea with the 0020514 -- the symtopms are similar and there the issue was that 'Hide editor' had 'MenuButton' class instead of 'ToolButton' so it was expanding something like "empty menu" resulting in the issue.. So maybe the fix would be deirectly in MenuButton class so that issue like this can't even happen..

Ludek

2024-06-10 14:15

developer   ~0075863

Last edited: 2024-06-10 14:32

It was a general issue in Menu class, when Menu was created with empty menuitems (undefined) and then attempted to show it resulted in the mentioned issue.. (main window not accepting keystrokes, but Tab key worked to switch Control)

I have made a generall fix directly in the Menu constructor in build 3030
So please re-test in 3030

Ludek

2024-06-10 15:28

developer   ~0075864

Actually found that it has been caused by fix of 0020960 => i.e. the crash no longer appears on menu open, but results in not accepting keystrokes in main window
=> Fixed in 3030