View Issue Details

IDProjectCategoryView StatusLast Update
0019435MediaMonkey 5Tagging / organizing (properties / auto-tools)public2022-11-08 12:51
Reporterlowlander Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.4 
Target Version5.1Fixed in Version5.1 
Summary0019435: Improve error handling for Artwork lookup failures
DescriptionAs previously raised in 0019418, currently when Artwork lookup fails there is no feedback to the user that the process isn't working. It leads to users endlessly waiting for a process that has failed.

1) Including a progress indicator would help users understand how long the lookup process will still take.

2) When Artwork lookup fails:
a) If MM is aware of failure (unexpected response), indicate via Toast that lookup failed
b) If MM isn't aware, set a timeout for Artwork lookup, indicate via Toast that lookup failed

3) When user enters a new search term, allow user to start Search (currently disabled till search finishes)
a) Enable Search button when user changes search query
b) Auto-start search when user changes search query
TagsNo tags attached.
Fixed in build2800

Relationships

related to 0019418 closedmichal Artwork lookup fails 

Activities

michal

2022-10-12 17:54

developer   ~0069768

Last edited: 2022-10-12 17:55

1) we cannot predict how long the lookup will take, it depends on how quickly Google/Bing return the results. That is why we have progress circle there.
2) when lookup fails, we simply do not show results and hide progress circle. I think it is clear and no additional toast is needed. Problem with infinitive progress was not intended, it was bug and should be ok already from last 5.0.4 builds.
3) I do not think we should start search automatically, it would cause searching too soon with incomplete search phrase. User simply write search phrase and press Enter, it is OK I think.

So I think the only thing to implement is to add ability to cancel running search in case user changes search phrase. Even though in most cases it is quite hard to make it, user has to have quite slow Internet connection for this.

michal

2022-11-08 12:51

developer   ~0070199

Fixed in build 2800. Change in search term now automatically cancels previous search, next search can be started by pressing Enter or Search button.