View Issue Details

IDProjectCategoryView StatusLast Update
0019418MediaMonkey 5Tagging / organizing (properties / auto-tools)public2022-11-04 20:30
Reporterlowlander Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.4 
Target Version5.1Fixed in Version5.0.4 
Summary0019418: Artwork lookup fails
Description1) Seen with 2667 and 2627 the Artwork lookup fails to find any Artwork. For Rusty changing the search terms does get results after initial failure.

2) For me changing search terms does not enable the Search button on the Artwork lookup window.
Additional InformationTicket 4862
TagsNo tags attached.
Fixed in build2668

Relationships

related to 0019249 closedmichal Artwork search does not return results. 
related to 0019435 resolvedmichal Improve error handling for Artwork lookup failures 

Activities

lowlander

2022-10-02 15:52

developer   ~0069611

1) Is set to be fixed in 0019249

michal

2022-10-03 12:00

developer   ~0069620

2) it is by design - you cannot start new search before finishing previous search to avoid conflicts. In this case the search was not working (fixed in 0019249), so it did not enable search button. It should be ok now.

lowlander

2022-10-04 21:14

developer   ~0069647

1) It works on 2668. If we have multiple Artwork providers, should there be a
a) timeout after which the next provider is attempted.
b A timeout after which MediaMonkey shows Search failed instead of the current eternal searching?

2) OK, and verified working on 2668 when search works. However there is no feedback to the user why Search button remain greyed out. MediaMonkey could instead:

2a) There should be a method to Cancel lookup, so user can start a new search.
2b) Edit of search terms should be disabled while search isn't finished
2c) Search button has tooltip to show why it's disabled.

peke

2022-10-16 21:02

developer   ~0069825

Verified designed behavior in 2672

Like @Rusty I can't replicate grayed Search except in case @Michal describes where search is already in progress.

peke

2022-11-04 20:30

developer   ~0070154

Extensively tested Art lookup in 2681 due the several user reports and have not seen any more issues,

Closing.