View Issue Details

IDProjectCategoryView StatusLast Update
0019192MediaMonkey 5Extensions frameworkpublic2022-06-24 21:28
Reporterdrakinite Assigned To 
PriorityhighSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.4 
Target Version5.0.4Fixed in Version5.0.4 
Summary0019192: Cannot use asJSON on an Extension object (87990000)
DescriptionAttempting to use asJSON on an Extension object causes a crash because it does not override the method getPersistentID.

Since the "id" value is -1, it makes sense to simply return the same value for persistentID, to allow MM to not crash when a curious developer attempts to retrieve its asJSON value.
TagsNo tags attached.
Fixed in build2655

Activities

drakinite

2022-06-23 00:26

developer   ~0068653

Fixed in 2655

peke

2022-06-24 21:28

developer   ~0068679

Verified 2655

MM do not crash if retrieved asJSON value.