View Issue Details

IDProjectCategoryView StatusLast Update
0019133MediaMonkey for AndroidNow Playingpublic2022-07-14 08:52
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionreopened 
Product Version2.0.0 
Target Version2.0.0Fixed in Version2.0.0 
Summary0019133: Tweaks to the Playing views' usability
DescriptionThe Playing views can improve in a few areas with some tweaks:

a) Track Name is often truncated due to the size of the text and because there are other icons on the row. Solution is to reduce the Title font size a bit, and position it so that it isn't constrained by any other content (e.g. an icon) in the row. In the proposed image, it is positioned below the album art so that setting ratings (a common task) is more accessible.
b) The menu button is missing in this view. This isn't critical but including it could make navigation easier for some users.
c) Toggling to the Playing queue is non-obvious (uses a floating action button which normally used for an action). A possible approach would be to use a navigation bar in the Playing menu (YT Music does something similar). This would make the Playing screen similar to the content navigation screen, and make it much easier to switch between the list/artwork/lyrics. In addition, 2 other hints appear in the proposed UI:
- 'Playing' (just like e.g. 'Music' or 'Rock' appear in the content navigation screens)
- 'v' A button indicating that the Playing screen is collapsible
e) Commands should be optimized:
. i) Share with... --> Share (this is standard terminology on Android)
. ii) Several commands apply to all Playing screens and shouldn't appear just in the Album Art screen. These include:
. - - Cast command should be accessible in any Playing view (and not hidden in an overflow menu)
. - - Sleep command should ideally be accessible in any Playing view (perhaps next to the cast icon?). Also, it currently doesn't look like a clock or timer. Lastly, there should be visual feedback when it is active.
. iii) Contextual commands can appear in their relevant contexts. e.g.
. - - Playing - Art: Image with Pencil icon could toggle delete/gear icons on the image. Pencil icon could activate the Properties dialog.
. - - Playing - lyrics: Delete / Search buttons
TagsNo tags attached.
Fixed in build1020

Relationships

related to 0019139 resolvedmartin Swipe transition can be smoother 
related to 0019207 resolvedmartin UI issues after looking up Artwork 
related to 0019206 resolvedmartin If AA is missing, find AA button should appear by default 
related to 0019208 resolvedmartin Issues in NP Lyrics view 

Activities

rusty

2022-05-31 05:39

administrator  

MMA2_playing.jpg (46,902 bytes)   
MMA2_playing.jpg (46,902 bytes)   

martin

2022-06-15 20:28

developer   ~0068542

Preview of the new layout made in build 2.0.0.1019

rusty

2022-06-17 03:01

administrator   ~0068578

Last edited: 2022-06-21 18:41

Looks and works amazing!

I would just suggest a couple of tweaks:
a) The star ratings are hard to adjust correctly because they're too small (at list on my Pixel 5a)
b) The overflow menu for the Track (Add to Playlist, Find more from, ....) is next to the star ratings. It would probably be better to place it next to the Title (or perhaps next to the Artist to conserve space for the title) so that it's more obvious what it applies to.
c) Currently, navigation within Now Playing views is a bit problematic:
. i) switching between Art and Queue is quite common, but the user has to reach all the way to the top of the UI
. ii) with the current layout, users expect to swipe to switch views (and this conflicts with the swipe BACK/NEXT functions in this view
A possible approach to resolve this could be:
- Position the queue/art/lyrics tabs at the bottom (above the player) instead of at the top
- (optional) Have different swipe actions on the track/AA switch tracks / swipe actions below the track switch views.
d) It would be useful if the Playing mode (Queue/Art/Lyrics) would persist. i.e. if the user:
1 switches from Music to Playing
2 switches from Art to Queue
3 switches back to Music
4 switches back to Playing
--> Currently Playing:Art displays, and the user would expect Playing:Queue to display

martin

2022-07-14 08:52

developer   ~0068818

Fixed in build 2.0.0.1020