View Issue Details

IDProjectCategoryView StatusLast Update
0018957MediaMonkey 5Otherpublic2022-05-07 07:02
Reporterdrakinite Assigned To 
PriorityurgentSeveritycrashReproducibilityhave not tried
Status resolvedResolutionopen 
Product Version5.0.3 
Target Version5.0.3 
Summary0018957: MM5 window freeze when playing YouTube while MM is minimized
DescriptionLog ID: EB3FB131
Response from user: "I think it was because I hit play on youtube online and then instantly minimized the player. I think I messed with a buffer"
Tagstodoc-KB
Fixed in build

Relationships

related to 0018609 closedLudek Some users can't run MM5 (until HW accelaration is disabled) 
has duplicate 0018959 closedmichal Crash/stall when playing YouTube while MM is minimized 
has duplicate 0018958 closedLudek "Unknown thread" exception after PC wake up on playback restoring 
related to 0018995 feedbackrusty Consider adding HW acceleration switch to Options > Performance 

Activities

drakinite

2022-04-01 18:58

developer  

image.png (21,730 bytes)   
image.png (21,730 bytes)   
image-2.png (172,896 bytes)   
image-2.png (172,896 bytes)   

Ludek

2022-04-04 13:04

developer   ~0067417

Last edited: 2022-04-04 14:09

View 5 revisions

This is same user as in 0018959
It is again UI freeze log ( EB3FB131 )

This time on line
ODS('**** focusControl: ' + this.constructor.name);
in control.js

which is particularly strange as it just tries to output debug message.

Maybe the 'focus' event is called too often for some reason? The DbgView part is missing in the ELF.
If it is still reproducible for the user then please try to catch it in standard debug log using DbgView and attach.

Thx

EDIT: It would be also valuable to try:
1) whether the freeze is reproducible with regular build too? (i.e. not the debug to be sure that it is not a false positive freeze by Eureka)
2) whether the freeze is reproducible with using MediaMonkey_NoGPU.bat (i.e. without HW acceleration)

drakinite

2022-04-05 01:31

developer   ~0067424

He did a bunch more testing, and confirmed that it's actually 2) which stopped the issue from occurring. Couldn't reproduce the UI freezing when running without HW acceleration, but he could reproduce it on both build types when running it normally.

Ludek

2022-04-05 14:33

developer   ~0067426

Last edited: 2022-04-05 14:38

View 3 revisions

Thx, could you please ask him to put chrome://gpu to the address bar of Chrome browser and share the output?
in case he is using Edge browser then use edge://gpu/

We need to ensure that his GPU isn't blacklisted and if it is then we should add a mechanism to detect blacklisted GPUs and run MM without HW acceleration (related to issue 0018609)

drakinite

2022-04-05 20:16

developer   ~0067442

I think blacklisting the GPU would be more harm than help. For some reason, when he runs MM with HW acceleration disabled, SVG icons are aliased. Additionally, because disabling HW acceleration causes HUGE CPU usage, it should be a last resort.

Asked him for the DbgView log & GPU info now, however.
image-3.png (988 bytes)   
image-3.png (988 bytes)   
image-4.png (4,471 bytes)   
image-4.png (4,471 bytes)   

drakinite

2022-04-05 20:39

developer   ~0067443

I could reproduce the issue by opening a game (The Witcher 3) while MM was minimized playing a YouTube playlist. There's no explicit crash, and it continues to send debug messages to DbgView. The attached log includes about 3-4 minutes of idle messages as I was typing out this note.

I forgot to include this recording he made. Turn the volume up, his voice is quiet. https://files.drakinite.net/2022-04-03_17-53-37.mp4
Youtube.m3u (8,160 bytes)   
#EXTM3U
#EXTINF:213,Black Gryph0n;Baasik - Faster Than You Know
https://www.youtube.com/watch?v=8JJg9114bgs
#EXTINF:270,Black Gryph0n;Baasik - Quest (This Can't Be All)
#EXTINF:206,Black Gryph0n;Baasik - Crusader (Are We There Yet)
https://www.youtube.com/watch?v=K4bBNbiVrus
#EXTINF:187,Black Gryph0n;Baasik - Tell Me
https://www.youtube.com/watch?v=-hZY8ibqKyA
#EXTINF:283,Black Gryph0n;Baasik - Moonlight
https://www.youtube.com/watch?v=XDD_ZAeFWOI
#EXTINF:214,Black Gryph0n;Baasik - Set in Stone
#EXTINF:305,Black Gryph0n;Baasik - Academy
https://www.youtube.com/watch?v=sXt5QHHq5wM
#EXTINF:266,Black Gryph0n;Baasik - IMmortal
https://www.youtube.com/watch?v=r0obQVwFL6o
#EXTINF:203,Black Gryph0n;Baasik - Taking Off
https://www.youtube.com/watch?v=K8jp2JzDklA
#EXTINF:246,Black Gryph0n;Baasik - Sight Unseen
https://www.youtube.com/watch?v=RrdShEw0UGY
#EXTINF:210,Black Gryph0n;Baasik - Zero Gravity (Feat. Michelle Creber)
https://www.youtube.com/watch?v=LEnxIbwlNG8
#EXTINF:290,Black Gryph0n;Baasik - Another End
https://www.youtube.com/watch?v=Bo3W4dRyBfo
#EXTINF:294,Michelle Creber;Black Gryph0n;Baasik - Getting Stronger
https://www.youtube.com/watch?v=6pp0kdfFzM0
#EXTINF:249,Black Gryph0n;Michelle Creber - Here We Are
https://www.youtube.com/watch?v=OOau641LkuI
#EXTINF:229,Black Gryph0n;Michelle Creber - Play
https://www.youtube.com/watch?v=LEnxIbwlNG8
#EXTINF:172,Michelle Creber - A Bad Idea
https://www.youtube.com/watch?v=HCNdk85OxRE
#EXTINF:215,Black Gryph0n - Fighting Back
https://www.youtube.com/watch?v=6Izcp-9naQo
#EXTINF:221,Michelle Creber;Black Gryph0n - Nervous
https://www.youtube.com/watch?v=7tYtVfytQ30
#EXTINF:270,Black Gryph0n;Michelle Creber - So Far Away
https://www.youtube.com/watch?v=aoOg0yNKSxQ
#EXTINF:259,Black Gryph0n - Say
https://www.youtube.com/watch?v=8dHvT70TjHM
#EXTINF:222,Michelle Creber - Bound to Break
https://www.youtube.com/watch?v=ttdzpObKMbE
#EXTINF:203,Michelle Creber;Black Gryph0n - Ice
https://www.youtube.com/watch?v=iF1oK65_zbA
#EXTINF:237,Black Gryph0n;Michelle Creber - Equality
https://www.youtube.com/watch?v=nZrdeMWWpAQ
#EXTINF:227,Michelle Creber;Black Gryph0n;Baasik - Getting Stronger (Remix)
https://www.youtube.com/watch?v=sPHyW7dygR8
#EXTINF:174,Black Gryph0n - Last Chance
https://www.youtube.com/watch?v=nXQvwBvpEU0
#EXTINF:231,Black Gryph0n - What You Need
https://www.youtube.com/watch?v=tmlLt_9Jty8
#EXTINF:210,Black Gryph0n - Letdown
https://www.youtube.com/watch?v=dTgKnmMHF50
#EXTINF:177,Black Gryph0n - Show Me (What You Got)
https://www.youtube.com/watch?v=zCHwPutR0Ak
#EXTINF:278,Black Gryph0n - Promise
https://www.youtube.com/watch?v=9o5exGqcdgs
#EXTINF:229,Black Gryph0n - Homesick
https://www.youtube.com/watch?v=UY2VLdAApm8
#EXTINF:285,Black Gryph0n - Wander
https://www.youtube.com/watch?v=pbRD1JKOV8k
#EXTINF:233,Black Gryph0n - Diamond
https://www.youtube.com/watch?v=ONlT7CoQEB0
#EXTINF:211,Black Gryph0n - (In the Rough)
https://www.youtube.com/watch?v=Lm0J7EKakIA
#EXTINF:189,Black Gryph0n - Better
https://www.youtube.com/watch?v=PrMjrvz5hyc
#EXTINF:231,Black Gryph0n - Magic
https://www.youtube.com/watch?v=liTSrukzOi4
#EXTINF:243,Black Gryph0n - IMmortalized
https://www.youtube.com/watch?v=aysvb0edYnY
#EXTINF:245,Black Gryph0n;Michelle Creber - Here We Are
https://www.youtube.com/watch?v=OOau641LkuI
#EXTINF:293,Silva Hound;Black Gryph0n - EGOMANIA
https://www.youtube.com/watch?v=YBD758_JOy8
#EXTINF:131,LilDeuceDeuce;TomSka;Black Gryph0n - Beep Beep I'm a Sheep (feat. TomSka & Black Gryph0n)
https://www.youtube.com/watch?v=CZlfbep2LdU
#EXTINF:118,TheFatRat - Warrior Song
#EXTINF:122,TheFatRat - Origin
https://www.youtube.com/watch?v=gZIDNZh9U14
#EXTINF:50,TheFatRat - Ascendancy
#EXTINF:82,TheFatRat - Nemesis
https://www.youtube.com/watch?v=2gP2obD8yrc
#EXTINF:107,TheFatRat - Origin Reprise
https://www.youtube.com/watch?v=GaLMjJZlEzk
#EXTINF:163,TheFatRat - Elevate
#EXTINF:49,TheFatRat - Kingdom Come
https://www.youtube.com/watch?v=2tptCDQqIt8
#EXTINF:80,TheFatRat - Mad Moon Falling
https://www.youtube.com/watch?v=q6Gxl6YJATw
#EXTINF:115,TheFatRat - Threnody
#EXTINF:139,TheFatRat - Envelope
https://www.youtube.com/watch?v=F1AgdpwdGkk
#EXTINF:141,TheFatRat - Reminiscence
https://www.youtube.com/watch?v=ulhh1dAxzU4
#EXTINF:140,TheFatRat - Afterlife
#EXTINF:222,TheFatRat;RIELL - Hiding In The Blue
#EXTINF:188,TheFatRat - Arcadia
#EXTINF:167,TheFatRat;RIELL - Pride & Fear
#EXTINF:192,TheFatRat - Upwind
https://www.youtube.com/watch?v=VBL7nt36yTM
#EXTINF:192,TheFatRat;Cecilia Gault - Our Song
#EXTINF:190,TheFatRat;Cecilia Gault - Violet Sky
https://www.youtube.com/watch?v=ScgbJmt-Hng
#EXTINF:219,TheFatRat;Everen Maxwell;Lindsey Stirling - Warbringer
#EXTINF:210,TheFatRat - Fire
https://www.youtube.com/watch?v=1RiaSfzxS90
#EXTINF:191,TheFatRat;Anjulie - Love It When You Hurt Me
https://www.youtube.com/watch?v=Uc59ulnJI2o
#EXTINF:199,TheFatRat;Anjulie - Let Love Win
https://www.youtube.com/watch?v=hIaYzwf0A8A
#EXTINF:214,TheFatRat - Never Be Alone (Michael Jan remix)
#EXTINF:238,TheFatRat - Splinter
https://www.youtube.com/watch?v=SVU0O5ZPRcY
#EXTINF:315,TheFatRat - Splinter
#EXTINF:257,TheFatRat - Telescope
#EXTINF:208,TheFatRat - Infinite Power!
https://www.youtube.com/watch?v=3aLyiI2odhU
#EXTINF:228,TheFatRat - Windfall
https://www.youtube.com/watch?v=jqkPqfOFmbY
#EXTINF:140,TheFatRat - Afterlife
https://www.youtube.com/watch?v=9KlponQf5Bk
#EXTINF:50,TheFatRat - Ascendancy
https://www.youtube.com/watch?v=77fZT0rldwQ
#EXTINF:163,TheFatRat - Elevate
https://www.youtube.com/watch?v=d9sDY3iZB0M
#EXTINF:139,TheFatRat - Envelope
#EXTINF:49,TheFatRat - Kingdom Come
https://www.youtube.com/watch?v=2tptCDQqIt8
#EXTINF:80,TheFatRat - Mad Moon Falling
https://www.youtube.com/watch?v=q6Gxl6YJATw
#EXTINF:82,TheFatRat - Nemesis
https://www.youtube.com/watch?v=2gP2obD8yrc
#EXTINF:122,TheFatRat - Origin
https://www.youtube.com/watch?v=gZIDNZh9U14
#EXTINF:107,TheFatRat - Origin Reprise
https://www.youtube.com/watch?v=GaLMjJZlEzk
#EXTINF:141,TheFatRat - Reminiscence
#EXTINF:115,TheFatRat - Threnody
#EXTINF:118,TheFatRat - Warrior Song
https://www.youtube.com/watch?v=I3Alq3OnXu8
#EXTINF:5175,Archie;TheFatRat - Pony Up Podcast, Episode 1: TheFatRat Guest Mix
https://www.youtube.com/watch?v=GKVHBHgLG-o
#EXTINF:29,[no artist] - Intro
#EXTINF:81,Archie - Leto
https://www.youtube.com/watch?v=tHQKLpw_4Gk
#EXTINF:0,Archie - Leto (Aaron Wayne remix)
#EXTINF:0,Hardwell;Mitch Crown - Call Me A Spaceman (extended mix)
#EXTINF:246,TON!C - Phony
https://www.youtube.com/watch?v=Nio6xCGPYnM
#EXTINF:5182,Archie;Polina - Here and Now
https://www.youtube.com/watch?v=KXHCn2bNB9U
#EXTINF:210,Martin Solveig - The Night Out (Madeon remix)
https://www.youtube.com/watch?v=5n-_9ZjwRC4
#EXTINF:0,Archie;Anna Yvette - No Apologies
#EXTINF:0,Hypster - Nitro Party Music (Heren remix)
#EXTINF:0,Archie;Taio Cruz;Pitbull;Nadia Ali - Guess Who's Hungover (Childz Play mashup)
#EXTINF:0,Henrix - Let's Rave
#EXTINF:343,Steve Angello;AN21 - Valodja (Samual James remix)
https://www.youtube.com/watch?v=rE6qNyPJ7y4
#EXTINF:140,Yuna - Live Your Life (Jakob Liedholm & Carnage remix)
https://www.youtube.com/watch?v=PISg167ora8
#EXTINF:0,Archie - Our World
#EXTINF:217,Archie;Anna Yvette - Villo
https://www.youtube.com/watch?v=iLWECPgMf9o
#EXTINF:198,Archie;Jakob Liedholm - Famous
https://www.youtube.com/watch?v=xr67715vxw4
#EXTINF:190,Archie;Nicky Romero;Calvin Harris - WTF Flash Fire (Archie mashup)
https://www.youtube.com/watch?v=GKVHBHgLG-o
#EXTINF:192,EDX;John Williams - Give It Up For Love (Mysto & Pizzi Dub)
https://www.youtube.com/watch?v=EoACd3vM6bs
#EXTINF:231,Fareoh;Archie - Feathers
https://www.youtube.com/watch?v=UoFpZKph980
#EXTINF:210,Foster the People - Don't Stop (TheFatRat remix)
https://www.youtube.com/watch?v=GHiovIidNas
#EXTINF:0,Modulation - Groovy Movie
#EXTINF:0,Noisestorm - Renegade
#EXTINF:270,The Knocks - Brightside (TheFatRat Remix)
#EXTINF:105,Fatso - Together (Rabbit Killer remix)
https://www.youtube.com/watch?v=1ox-uuJ5dyE
Youtube.m3u (8,160 bytes)   
gpu crash JL.zip (373,039 bytes)

Ludek

2022-04-06 16:14

developer   ~0067461

Last edited: 2022-04-06 16:57

View 4 revisions

Based on the gpu.pdf HW acceleration seems fine and enabled for him -- so this shouldn't be an issue.
The log System_hang_while_using_VS_code.LOG isn't of any use, it just outputs our standard messages, but the bug is most probably inside Chromium.

@Petr, could you please create a build with with Chromium debug messages enabled to see more?
@drakinite: Ask Tim to open support ticket to have direct comminication channel with him

Ludek

2022-04-06 17:02

developer   ~0067465

Last edited: 2022-04-06 17:26

View 3 revisions

BTW: I am unable to replicate, but this one sounds very similar: https://support.google.com/chrome/thread/82011253/chome-freezes-if-i-minimize-then-maximize-the-screen-ie-press-the-little-box-in-top-left?hl=en and disabling HW acceleration in Chrome did the trick. This confirms the user's tests ( 0018957:0067424 ) and that it is something between Chromium and GPU.

Also these links confirms that disabling HW accelaration does the trick for the similar issue:
https://bbs.archlinux.org/viewtopic.php?id=198335
https://askubuntu.com/questions/1300640/20-04-google-chrome-opens-but-freezes-when-i-enter-full-screen-in-youtube-or-wh

Left assigned to Petr to create a build with with Chromium debug messages enabled to see more...

petr

2022-04-07 15:40

developer   ~0067485

Chromium logging enabled for a next build

Ludek

2022-04-14 19:04

developer   ~0067544

Assigning to Jordan to generate debug log using the build with Chromium logging.

drakinite

2022-04-14 21:58

developer   ~0067548

Attaching log from build 2614 with the issue reproduced. It's quite long.
18957-build-2614.zip (95,094 bytes)

Ludek

2022-04-19 20:56

developer   ~0067590

Last edited: 2022-04-21 17:18

View 9 revisions

I am unable to replicate at all, but findings so far (debugging with Jordan and Tim) are:

1) The freeze occurs when there is YouTube playback and MM5 window is minimized (and is about to be maximized from the taskbar)
2) The freeze occurs also in 5.0.2 -- so not related to recent Chromium update
3) The freeze does not occur with the MediaMonkey_noGPU.bat , i.e. with HW acceleration disabled -- this relates to the links in my previous note 0018957:0067465
4) It is browser process that freezes (not the render) and the last line from browser (B) in the log usually is:
MM5 [15868](B) Activating window file:///mainwindow.html

EDIT re item 4) We added more debug messages into TBrowserWindow.activate and the method seems to be performed as whole, i.e., it does not freeze in the method, but after executing this method (somewhere in the browser process).

Assigned to Petr whether he has an idea (as the window management in the Browser process is his code)

jiri

2022-05-05 13:54

administrator   ~0067997

Per IM discussion with the devs, it might by interesting to try to enabled chrome://flags/#ignore-gpu-blocklist.

Anyway, it looks like an issue that would be 'fixed' by 0018995.

petr

2022-05-06 07:55

developer   ~0068011

Based on tests ignore-gpu-blocklist switch didn't help

drakinite

2022-05-07 07:02

developer   ~0068056

FYI, interesting note.
Adding www.youtube.com as a Web bookmark, then playing songs on the YouTube web player, seems to NOT cause the issue. This means it must be something with the embedded YouTube player MM is using.