View Issue Details

IDProjectCategoryView StatusLast Update
0018846MediaMonkey 5Playbackpublic2022-07-25 09:34
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilitysometimes
Status resolvedResolutionreopened 
Product Version5.0.3 
Target Version5.0.4Fixed in Version5.0.4 
Summary0018846: Play audio --> crash 20E30000 (regression?)
DescriptionI left build 2607 playing audio overnight and at some point it crashed with crashlog 20E30000 .

I haven't seen this behavior in 5.0.2 so I suspect it's a regression.
TagsNo tags attached.
Fixed in build2654

Relationships

related to 0016940 closedmichal Plugin in_mfaudio does not use gapeless info contained in MP3 files 
related to 0019214 closedmichal Playback: On playback start MM cuts part of Track (Regression) 
related to 0019243 resolvedmichal Performance/Playback issue when playing m4a tracks (regression) 
related to 0019280 resolvedmichal Playing MM for a while -> crash 22F30000 (Access violation in in_mfaudio.dll) 

Activities

michal

2022-02-15 15:43

developer   ~0066980

Last edited: 2022-02-15 15:44

View 2 revisions

I found more similar reports received during last few weeks. It seems to be always related to M4A file and in_mfaudio plugin.

rusty

2022-02-15 19:14

administrator   ~0066985

I tried to replicate it again without success (leaving MM playing for 45 minutes including m4a files). But when I tried to close MM it resulted in 2 other crashlogs: 26D30000 , and 08400000 .

michal

2022-04-18 10:22

developer   ~0067556

I went through bugreports from the last versions and no similar problem with M4A and mfaudio was included, probably some of the code adjustments during previous weeks worked. Resolving. Reopen with new report, if this happen again.

michal

2022-06-16 12:21

developer   ~0068555

Reopened, the problem seems to be still there, crash report 89E90000 seems to be the same problem during start of M4A playback.

michal

2022-06-16 16:51

developer   ~0068560

Fixed in build 2653. It was regression introduced with fix of 0016940, problem could randomly occur only for files with post gap info set (for gapeless playback).

peke

2022-06-17 23:01

developer   ~0068587

Verified 2653

Waiting for user confirmation and closing.

peke

2022-06-22 10:42

developer   ~0068648

Fix introduced regression and some files do not play correctly.

Sending you few offline.

1919 and 2627 play them normally.

michal

2022-06-22 12:25

developer   ~0068649

Fixed in build 2654.

peke

2022-06-22 22:51

developer   ~0068651

Verified 2654 Sound is not Garbled anymore and track plays normally, but WaveForm is calculated incorrectly.

peke

2022-06-22 22:51

developer   ~0068652

image.png (58,517 bytes)   
image.png (58,517 bytes)   

michal

2022-06-23 06:06

developer   ~0068655

I cannot reproduce, it won't be regression, but some specific timing and lost refresh after wavefrom bar size change.

michal

2022-06-23 11:46

developer   ~0068657

Last edited: 2022-06-23 11:46

View 2 revisions

Closing, as it is most probably different issue. In case you reproduce it with the next build, please insert it to separate issue with repro steps and affected file, thanks.

michal

2022-06-23 12:31

developer   ~0068658

Analyzed more and seems to caused by already fixed regression 0019214, please retest in the next release.

peke

2022-06-24 21:26

developer   ~0068678

Verified 2655

All looks fixed now.

peke

2022-07-18 09:40

developer   ~0068848

reopen Possible new issue log id C33D6157

michal

2022-07-25 07:58

developer   ~0068887

Reports C33D6157 are hard to analyze app freezes, I do not see any relation to this issue.
New crashes related to in_mfaudio tracked as 0019280