View Issue Details

IDProjectCategoryView StatusLast Update
0018762MediaMonkey for AndroidSynchronizationpublic2022-04-06 12:13
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.0 
Target Version2.0.0Fixed in Version2.0.0 
Summary0018762: Sync fails (black 'Synchronization' screen)
DescriptionSync always fails with build 1014.

1 Attempt playback of tracks from MM5 build 2061 via UPnP
--> it works as expected
2 Click 'Sync now' in the menu
--> Sync server appears as 'On'
3 Configure the 'Internal shared storage' (last synced 10/26/21)
4 Initiate sync
--> Synchronization Title bar is shown with black screen below
5 If I try to do this again without going through the wizard
--> Auto-sync server content shows:
Chosen server content:
TODO to next build

So I guess that even though the Wizard allows content to be selected, it doesn't actually get committed.
TagsNo tags attached.
Fixed in build1017

Relationships

related to 0018899 resolvedmartin Initiating Sync via Media Content screen often fails 

Activities

martin

2022-01-20 18:14

developer   ~0066690

I can't replicate it, Can you send logs?

rusty

2022-04-04 14:03

administrator   ~0067419

Tested in build 1016 with slightly different repro steps:
1 Click Menu button > Sync Now
--> Synchronization screen opens and remains black

Debug log: H255L2CT7X

I believe that the issue can be triggered by scenarios in which the Synch server isn't fully configured or somehow becomes partially unconfigured. In the case above, the Sync server had previously been configured, but because it's during the trial period, MMA seems to 'lose' the sync server setting. To workaround this, the user must:
2 Click Menu > Settings > Library & Sync > Select Sync Server
-->
'Wi-Fi Sync can e used on a trial basis.
Days remaining: 2 days
Please consider purchasing the addon
[Cancel] [Continue] [Buy]
3 Click 'Continue'
4 Click the BACK arrow 3x (i.e. Navigate back to the main menu
5 Click 'Sync now'
--> This time sync initiates as expected

martin

2022-04-06 12:13

developer   ~0067459

Fixed in build 2.0.0.1017