View Issue Details

IDProjectCategoryView StatusLast Update
0018712MediaMonkey 5Playbackpublic2022-04-18 23:04
Reportermichal Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0.2 
Target Version5.0.3Fixed in Version5.0.3 
Summary0018712: Garbled playback / white noise in playback with WASAPI exclusive mode "Use format of original track"
DescriptionWhen using WASAPI exclusive mode with "Use format of original track" setting, these steps lead to garbled/white noise playback:
Steps To Reproduce1) play any audio file which has sample rate 44100
2) skip to any audio file with significantly different sample rate, like 96000 or 192000 -> playback is distorted

Playback is again ok, when stopped and started to play again.
Additional InformationTicket 3422
TagsNo tags attached.
Fixed in build2602

Relationships

related to 0007146 closedjiri MediaMonkey 4 Miscellaneous WASAPI plug-in problems 

Activities

michal

2021-12-28 10:29

developer   ~0066496

Last edited: 2021-12-28 12:43

View 2 revisions

It seems to be related to the situation, where audio device does not support format of the original track, in my case 192000Hz 24bit audio. Then it works for the first time (played correctly as 32bit audio), but when e.g. I double-click the same track again and in fact restart playback of the same file, it plays distorted. So when testing, you need to find file, which manifests this bug for your system and audio device. It seems 24bits are problem, I have similar problem with 44100Hz 24b.
It is not regression, MM4 has the same problem.

michal

2021-12-28 16:34

developer   ~0066497

Fixed in build 2600.

michal

2021-12-29 09:15

developer   ~0066500

Original problem is fixed, but when user enables crossfade, it is back. It is caused by the fact, that if the next file has different sample size than the previous one, we cannot do crossfade in this exclusive mode, we can play only one output format at once. It could be probably fixed only by not doing crossfade in this case.

michal

2021-12-29 10:43

developer   ~0066501

Fixed too.

peke

2022-01-07 18:13

developer   ~0066575

Reopen Not fixed.

peke

2022-01-07 18:18

developer   ~0066576

Going from 192 -> 48 fails, but going from 48 -> 192 looks like work.
image.png (17,231 bytes)   
image.png (17,231 bytes)   

michal

2022-01-08 09:49

developer   ~0066586

I cannot reproduce, tried 3 different outputs, the same settings.

michal

2022-01-18 14:22

developer   ~0066663

Last edited: 2022-01-18 14:24

View 2 revisions

There were some significant adjustments in WASAPI. Please retest with 2602, if you still reproduce it, I am not able at all. Btw. crossfading output of different output formats is not possible (your setting).

peke

2022-01-22 19:32

developer   ~0066719

It doesn't Garble in 2603, but Crossfading from 48->192 works (if set 8s crossfade starts at 4s) but When going back from 192->48 New track is loaded on crossfade time and stays at 0 till previous track ends.

Is there way to check if sound card correctly set exclusive mode and freq?

michal

2022-01-23 18:05

developer   ~0066729

Last edited: 2022-01-23 18:06

View 2 revisions

I cannot reproduce, for me the same settings lead to waiting for the next track always for both combinations. As it should because of different exclusive output formats.

I can probably only add info to debug log, what output format was successfully set. Will do it to see what is exactly going on for you.

michal

2022-01-23 18:33

developer   ~0066730

We have it already there, see debug messages like "WASAPI: Initializing buffer for 192000/2/32", the last message of this kind before "WASAPI: Open() successfully finished" is the output format set.

peke

2022-04-18 23:04

developer   ~0067568

Resolving unable to replicate in past few versions of 5.0.3.

Verified 2615