View Issue Details

IDProjectCategoryView StatusLast Update
0018636MediaMonkey 5Extensions frameworkpublic2022-04-20 21:44
Reporterdrakinite Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.2 
Target Version5.0.3Fixed in Version5.0.3 
Summary0018636: Extensions with a period in the ID do not load properly
DescriptionDr.Sol's Perpetual: https://www.mediamonkey.com/addon_system/admin/download.php?record_id=746
Likely caused by MM thinking the folder is a file with extension ".Sol's Perpetual".

Instead of "fixing" this, I recommend that we enforce a new rule that addon IDs should be alphanumeric + space/hyphen/underscore/apostrophe/parens, to avoid any additional file confusion issues: [a-zA-Z0-9 -_'()]
TagsNo tags attached.
Fixed in build2600

Activities

drakinite

2021-12-11 16:58

developer   ~0066357

Adding parentheses to the list of allowed characters because we already have addons with parentheses.

drakinite

2021-12-11 17:07

developer   ~0066358

Testing note:
- Make sure that all installed addons display properly when opening the addons dialog. (If a currently-installed addon is seen as invalid, the text will not display even though the icon will.
- Try installing these sample addons and verify that they work/fail when they should.
shouldfail-slash.mmip (1,028 bytes)
shouldwork.mmip (1,024 bytes)
shouldwork2.mmip (1,051 bytes)
shouldfail-greek.mmip (1,030 bytes)

drakinite

2021-12-11 18:12

developer   ~0066359

Fixed in 5.0.3

peke

2022-04-20 21:44

developer   ~0067632

Verified 2615

Sample addons Install/fail as noted.