View Issue Details

IDProjectCategoryView StatusLast Update
0018500MediaMonkey 5Extensions frameworkpublic2021-11-06 18:48
Reporterdrakinite Assigned To 
PriorityurgentSeveritymajorReproducibilityN/A
Status feedbackResolutionreopened 
Product Version5.0.2 
Target Version5.0.3Fixed in Version5.0.2 
Summary0018500: Check for Addon Updates: Compatibility field is ignored
DescriptionWith multiple versions of MM5 out, new addons may depend on methods that have been added in 5.0.2+, such as getAllValues and setLessVariables. If a user hits Check for Updates and there is a new version of an addon whose Compatibility field is higher than the installed MediaMonkey version, it will still display as available and will install without notifying the user of possible incompatibility.

Proposed new functionality:
If a new addon version is available, but its "minimum compatible version" is higher than the currently installed MediaMonkey version, two things should occur:
1. Next to the "Update available (x.x.x)", to the left of the download button, a "⚠️" symbol should appear, with the tooltip "This addon version may be incompatible with MediaMonkey version ((installed version)). Addon is compatible with MediaMonkey version ((minimum version)) to ((maximum version))."
2. If the user downloads it anyway, in the Product Installation dialog, another warning should appear at the top, with the same message.

Optionally, there could be a link to open the addon's page on the website, with the text "Find other versions here"

This wouldn't help users who have MM5.0.0 and 5.0.1 installed, but it would help moving forward.
TagsNo tags attached.
Fixed in build2516

Relationships

related to 0013903 feedbackjiri Extensions: MM5 Extension Tweaks 

Activities

Ludek

2021-11-02 20:01

developer   ~0065653

Last edited: 2021-11-02 20:03

View 2 revisions

I think that there could be just indication of minimum version and the install shouldn't be possible at all (if the minimum version is higher than current MM5 version).

Assigning to Rusty as it requires new strings to include/review before translation.

rusty

2021-11-03 01:24

administrator   ~0065661

Strings:
1. "Update available (x.x.x)". I suppose you're referring to the existing "Update available" string?

2. Suggested Tooltip/Full warning message strings:
String 1: This update is compatible with %%.
String 2: The addon may not work correctly with %%.

e.g.
This update is compatible with MediaMonkey 5.2-5.9. The addon may not work correctly with MediaMonkey 5.1.

Re.: "Find other versions here", couldn't we just make addons that appear on the site hyperlinked?

drakinite

2021-11-03 01:55

developer   ~0065665

1. Yep.

Re hyperlinking: That *could* be possible, but I think that would require quite a bit of extra coding (To my knowledge, there's no way of determining whether an addon came from the site without pinging the addons API.)

Alternatively: If we put the hyperlink close to the version warning, we could get away with "Choose alternate". (It would have to be physically close to the warning, such as in the same line, so that the user understands the context.) Does that sound ok?

rusty

2021-11-03 04:13

administrator   ~0065667

Sounds good.

Ludek

2021-11-03 20:37

developer   ~0065686

Last edited: 2021-11-03 21:57

View 3 revisions

As discussed offline, currently the addon's site does not return the minimum supported version although the addon's submitter fills this info.
e.g. https://www.mediamonkey.com/addons/update.php?id=refreshSkinShortcut returns just XML with the addon's version.
i.e. the minimum supported MM version needs to be added

Assigned to Jiri to add this info.


EDIT1: I still believe that the minimum compatible MM version should be also part of the MMIP itself. For the cases when someone installs the update manually from the downloaded MMIP
EDIT2: The code with these two new strings is backed up in SVN:
'This addon is incompatible with current version of MediaMonkey'
'Please update to MediaMonkey %s or higher.'

Ludek

2021-11-05 17:12

developer   ~0065761

Last edited: 2021-11-05 17:12

View 2 revisions

Assigned back to me to support minAppVersion in info.json for 5.0.2
To be assigned back to Jiri for the server site support (post 5.0.3)

Ludek

2021-11-05 18:53

developer   ~0065767

Last edited: 2021-11-06 18:46

View 4 revisions

Fixed in 2516.

i.e.
- added minAppVersion support in info.json (part of MMIP) and added it to all scripts from the SampleScripts folder
- added minAppVersion support for both XML and JSON variant of the updateURL info

i.e. in case of https://www.mediamonkey.com/addons/update.php?id=refreshSkinShortcut
the XML should look like

<VersionMajor>1</VersionMajor>
<VersionMinor>0</VersionMinor>
<VersionRelease>2</VersionRelease>
<VersionBuild>0</VersionBuild>
<MinAppVersion>5.0.2</MinAppVersion>

in case of JSON the JSON should look like:

{
"version": "1.0.2",
"minAppVersion": "5.0.2"
}

The format can be either "5.0.2" or "5.0.2.2513"

peke

2021-11-06 18:25

developer   ~0065778

Verified 2516

Please triage for further progress by @jiri

Ludek

2021-11-06 18:47

developer   ~0065788

Last edited: 2021-11-06 18:48

View 2 revisions

OK, so assigned to Jiri to implement the server side.