View Issue Details

IDProjectCategoryView StatusLast Update
0018483MediaMonkey 5Main Panel: Toolbars & Menuspublic2021-11-03 19:43
Reporterpeke Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.2 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018483: Add Skin Options shortcut in View menu
Description1. Now that we have color changer and Material Design skins are joined we should add "Skin options" menu shortcut in View -> Skins and it should point to Tools -> Options -> Layout -> Skin

2. We should add a 'Configure' icon next to Skin name (just for skins with some options. eg. Color change, skin Dark/Light change)
TagsNo tags attached.
Fixed in build2514

Relationships

related to 0018449 closeddrakinite Enable skin options via info.json so skin developers don't have to write code 

Activities

rusty

2021-10-29 03:24

administrator   ~0065553

I'd suggest placing a [gear] icon next to the 'Material Design' skin.

peke

2021-10-29 10:54

developer   ~0065554

As talked offline with Jiri:
-----
wonder though, now that there're skin related options, what about to show a 'Configure' icon next to Skin name (just for skins with some options)? This way it'd be obvious that users can modify how the skin looks like.
-----

drakinite

2021-11-03 02:01

developer   ~0065666

Added in 2514.

Additional, related changes:
1) Selecting the current skin from the View submenu will no longer reload the window (because the skin is already selected)
2) app.currentSkin().path now contains the skin's full path, making it consistent with app.getSkins(). (I don't believe any code is affected, b/c app.currentSkin() is only used twice, and only uses "id".)

rusty

2021-11-03 19:43

administrator   ~0065680

Verified 2514.