View Issue Details

IDProjectCategoryView StatusLast Update
0018411MediaMonkey 5Conversion/Levelingpublic2021-10-15 21:39
Reportermichal Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0.2 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018411: Decoding of some DSF files end with crash
DescriptionUser sent us DSF files, which can play, but app crashes just after finishing decoding (e.g. after file is converted to any other format)
Additional InformationTicket 2866
TagsNo tags attached.
Fixed in build2509

Relationships

related to 0011184 resolvedrusty Add support for the DSD format 

Activities

michal

2021-10-13 09:18

developer   ~0065150

Fixed in build 2509. The crashing files have wrong info in the header, it does not correspond to the contents. MM5 now does not crash, but can sometimes generate some artifacts in audio near the end of the file, it is consequence of malformed file.

michal

2021-10-14 07:25

developer   ~0065189

I have to correct myself - the files are not malformed, there was really (already fixed) bug in decoding. There is one more thing - user file "04 Mutineer DSD256.dsf" is played correctly till the end, but when converted to other format, like WAV, there is "click" at the very end of the file, it should not be there most probably, analyzing.

michal

2021-10-14 09:06

developer   ~0065192

Resolving, the click was included in the original file data.

peke

2021-10-15 21:39

developer   ~0065253

Verified 2509

Unable to reproduce crash.