View Issue Details

IDProjectCategoryView StatusLast Update
0011184MediaMonkey 5Generalpublic2021-10-12 16:49
Reporterlowlander Assigned To 
PriorityurgentSeverityfeatureReproducibilityalways
Status resolvedResolutionreopened 
Target Version5.0.2Fixed in Version5.0.2 
Summary0011184: Add support for the DSD format
DescriptionAdd support for the DSD formats like .DFF and .DSF.


Sample converter: https://code.google.com/archive/p/dsd2pcm/source
DSF Format specs: http://dsd-guide.com/sites/default/files/white-papers/DSFFileFormatSpec_E.pdf
DSDIFF specs: http://www.sonicstudio.com/pdf/dsd/DSDIFF_1.5_Spec.pdf

Comparison description https://www.blisshq.com/music-library-management-blog/2016/03/15/dsd-versus-dsf-versus-dff-what-mean-audio-libraries/

Interesting description in Czech: https://www.svetaudia.cz/dsd-spasa-nebo-marketing-hudebniho-prumyslu/66
Additional InformationQHQ-695788, DAX-178532, BXI-261135, JJG-771-83405, TJD-290-36115, KWZ-238-53304, FGD-223-96758, TUD-551-74594, TUD-551-74594, DGG-711-90204
Ticket # 247, # 530
http://www.facebook.com/n/?MediaMonkey/posts/10151936128495853
http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=76820
http://www.mediamonkey.com/forum/viewtopic.php?f=4&t=62829
https://www.mediamonkey.com/forum/viewtopic.php?f=4&t=93637
Tagsdoc_help, todoc, web
Fixed in build2500

Relationships

related to 0018411 closedmichal MediaMonkey 5 Decoding of some DSF files end with crash 

Activities

michal

2017-07-13 11:19

developer   ~0048360

Last edited: 2017-07-13 11:27

View 3 revisions

There is Winamp plugin ( http://www.softpedia.com/get/Multimedia/Audio/Audio-Plugins/DSD-Plugin-for-Winamp.shtml ), which seems to play DSF and DFF files. The problem is, that it is somehow buggy - it works quite ok with Winamp and decoder.exe (used during conversions), but it sends wrong data to Write method of our output plugins (sends always buffer with length 6912 B, but the second half are only zeros, correct data are only in the first 3456 B, I did try to find the reason, why it works for decoder.exe and not for MM, but without success). We could hardcode reading only first half of the buffer for this plugin, but better would be to write our own format plugin with decoding and tagging support and with options to use better PCM quality, if demanded. There are also reports on Winamp forum, that the plugin is sometimes quite unstable.
Anyway, this plugin is currently usable for conversions from DSF and DFF files.

Ludek

2018-01-18 11:33

developer   ~0049538

Seems quite often requested feature, shouldn't the priority be higher?

peke

2019-01-14 21:17

developer   ~0052074

Last edited: 2019-01-14 21:27

View 2 revisions

Based on my investigation Yes all possible types of DSD are supported in FFDShow

Possible DSD types:
1) *.dff-file[DST{lossless compressed DSD}]
2) *.dff-file[DSDIFF{DSD compressed in DST}] which is recognised Foobar as "DSD" and LAVAudioDecoder or MPCAudioDecoder through [dsd_msdf]-codec.
3) *.dsf-file[DSD] which is recognised Foobar as "DSD" and LAVAudioDecoder or MPCAudioDecoder through [dsd_lsbf_planar]-codec.

 

MPCAudioDecoder(can grab native MEDIASUBTYPE_DS* formats) and LAVAudioDecoder(only can grab as compatibile MEDIASUBTYPE_FFMPEG_AUDIO format) not able to output with original Sample Rate all DSD formats:
- DSD64[2822,4 kHz] out on [352,8 kHz]
- DSD128[5644,8 kHz] out on [705,6 kHz]
- DSD256[11289,6 kHz] out on [1411,2 kHz]
- DSD512[22579,2 kHz] out on [2822,4 kHz]

 p.s. You can download free MPCAudioDecoder(from standalone_filters) here: https://sourceforge.net/projects/mpcbe/files/MPC-BE/Release%20builds/1.5.1/

peke

2019-01-14 21:26

developer   ~0052075

Last edited: 2019-01-14 21:42

View 4 revisions

Based on further tests many apps support payback of DSD while GraphStudioNex introduce artifact most likely due no resampling.

For testing I used sample files from http://dsdmaster.blogspot.com/p/blog-page.html , https://www.oppodigital.com/hra/dsd-by-davidelias.aspx and http://www.2l.no/hires/

Tag Support based on "DSFFileFormatSpec_E.pdf" should be easily archived using ID3v2 appended on the end of file, but correct position should be read from Format header

Encoder explanations https://diyaudioheaven.wordpress.com/digital/pc-software/compressing-dsd-files-with-wavpack-5/

peke

2019-01-18 04:03

developer  

rusty

2021-01-08 17:08

administrator   ~0061231

There have been quite a few requests for this. Since playback is basically working and tags are in a format we support, would it make sense to target this for 5.0.1 ?

michal

2021-01-08 18:00

developer   ~0061235

Yes, we can try to implement this in 5.0.1.

michal

2021-08-10 07:13

developer   ~0064363

Fixed in build 2500. We support playback of DSF and DFF and tagging of DSF. DFF standard does not include tagging support (only title, artist and some comment is supported, but not in unicode or UTF8), so we cannot tag them. Some apps use 'ID3 ' chunk, but it is not part of standard and people mostly use DSF, because of metadata support. In case it will be needed, we could add tagging to 'ID3 ' chunk too, now we only read it.

peke

2021-08-31 20:58

developer   ~0064443

Verified playback on 2500 by playing 100+ files of various DSF files for Mem leaks and crashes.

No issues found.

Tagging of DSF is briefly tested by Sync MM Library to DSF tags and other apps (foobar) without problems and show tags.

peke

2021-09-17 01:46

developer   ~0064705

Re verified 2502 on several new DSF files

michal

2021-09-19 07:38

developer   ~0064750

Conversion to DSD was not requested. It also does not make much sense, because user does not achieve anything by this conversion, DSD files are created during recording directly, it is different way of storing raw audio, other than PCM/WAV.

Reading/writing tags from/to DSF is covered by automatic regression tests.

The same ID3v2 tags like for MP3 files are supported, doc updated here: https://www.mediamonkey.com/wiki/WebHelp:About_Track_Properties/5.0

peke

2021-10-12 14:58

developer   ~0065125

Last edited: 2021-10-12 14:59

View 2 revisions

As noted in bug 0018411 looks like only some files can make issues, those I tested previously and now had no issues converting to WAV, FLAC, ALAC.

I would resolve it, new issues are handled in new bugs.

Re DSD as Destination format. I do not see the point of adding DSD, nor anyone ever requested it issue was with decoding and syncing the format never creating it.

Assigned to rusty for Help handling

rusty

2021-10-12 16:49

administrator   ~0065130

OK. Added tags to track documentation requirements (for LL and Rusty).