View Issue Details

IDProjectCategoryView StatusLast Update
0018299MediaMonkey 5Extensions (bundled)public2021-09-17 16:15
ReporterLudek Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018299: Export all playlists can freeze for large playlists/DBs
DescriptionOn LowLander's database the Export all playlists feature freezes UI and generates freeze logs (E7FECEA4, EFBEB73D, 8948CEA4)

Additional InformationApparently caused by the code in \Scripts\exportPlaylists\actons_add.js
function ExportM3Us
line 76: tracks.forEach(function (trck) { ...
where constructing the fout string isn't async and thus freezes UI (for large amount of tracks).

Solution is to use listAsyncForEach() that uses setTimeout once 100 items are performed.
TagsNo tags attached.
Fixed in build2503

Relationships

related to 0016283 closedmichal Missing 4.x Extensions 
related to 0018232 closedLudek Send to M3U uses absolute paths and ANSI encoding (unlike MM4) 

Activities

Ludek

2021-09-14 18:24

developer   ~0064619

Fixed in 2503

lowlander

2021-09-17 16:15

developer   ~0064729

Verified on 2503.