View Issue Details

IDProjectCategoryView StatusLast Update
0018232MediaMonkey 5Playlistspublic2021-09-29 15:06
ReporterLudek Assigned To 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018232: Send to M3U uses absolute paths and ANSI encoding (unlike MM4)
DescriptionIn MM4 exporting a playlist to M3U via Send to > M3U/XSPF playlist...
created relative paths with UTF8 encoding.

In MM5 it uses ANSI encoding and always absolute paths.

Reported at: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=99894
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=33&t=100236
TagsNo tags attached.
Fixed in build2503

Relationships

related to 0018299 closedLudek Export all playlists can freeze for large playlists/DBs 

Activities

lowlander

2021-09-14 14:37

developer   ~0064612

1) Export All Playlists still uses absolute Paths on export

2) Exporting network files uses absolute Paths (maybe by design), whereas local files use relative Path when exporting from Send To

3) Ideally this would be a setting in the Options (Tools > Options > Tags & Playlist) that allows the user to define if absolute or relative Paths should be used (and perhaps with a sub-option for network files)

Ludek

2021-09-14 18:14

developer   ~0064617

1) This used to be the case in MM4 too -- though I agree that this should be probably changed/unified

i.e. in 5.0.2 it is fixed to the degree of MM4 functionality
The rest targeted to 5.1..

Ludek

2021-09-14 19:40

developer   ~0064622

1) might be re-targeted to 5.0.2 per feedback here https://www.mediamonkey.com/forum/viewtopic.php?p=487002#p487002

Ludek

2021-09-15 19:18

developer   ~0064655

Last edited: 2021-09-15 19:49

View 2 revisions

1) is implemented in 2503, i.e. unified with the 'Export all playlists' script (which also improves performance of the script)

Ludek

2021-09-15 19:48

developer   ~0064656

Last edited: 2021-09-15 19:48

View 2 revisions

3) Added 'Use extended M3U' and 'Force relative paths' checkboxes (both enabled by default) in build 2503
Added to 'Tools > Options > Tags & Playlist'
The same checkboxes we already use in 'Sync Profile > Playlists' for device sync.

peke

2021-09-17 23:20

developer   ~0064739

Verified 2503
Confirmed both 1) and 3) fixes.