View Issue Details

IDProjectCategoryView StatusLast Update
0018084MediaMonkey 5Extensions frameworkpublic2021-11-08 15:41
Reporterdrakinite Assigned To 
PriorityurgentSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
Product Version5.0.2 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018084: MM5 Crashes when using 3D Album View
DescriptionIn some test cases when user enables 3D Album view MM5

As talked offline @Peke and @Lolander observe such behavior even https://threejs.org/examples/ renders normally on their PCs

Crash logs: A14A09A3, A14AA5D2, A14AE8EE, 8F780000

The last crash log (8F780000) occurs occasionally when closing or restarting MediaMonkey, not when enabling 3D Album View.
TagsNo tags attached.
Fixed in build2511

Activities

peke

2021-06-30 02:25

developer   ~0064115

New log A14AE8EE

drakinite

2021-07-09 22:44

developer   ~0064200

Got an access violation after closing MM5: log ID is 8F780000. Don't know whether it could be related to the album view.

peke

2021-07-17 03:02

developer   ~0064237

Looks like 0.1.2 Works after debugging.

drakinite

2021-07-17 03:41

developer   ~0064239

First three crash logs (A14A09A3, A14AA5D2, A14AE8EE) have been identified and resolved.

Last crash log (8F780000) is possibly unrelated. Michal said crashed during accessing SharedWindows.Count. Assigning to Petr to check.

petr

2021-10-20 10:24

developer   ~0065350

Fixed

peke

2021-10-22 15:57

developer   ~0065438

Verified 2511 and addon v0.2.4

Unable to replicate any of listed crashes.