View Issue Details

IDProjectCategoryView StatusLast Update
0017972MediaMonkey 5Main Panelpublic2021-10-21 20:31
Reporterlowlander Assigned To 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version5.0.1 
Target Version5.0.2 
Summary0017972: Sorting in List (by Album) shows hides files in Descending mode
DescriptionThere is a scenario in the Art (by Album) View where sorting on a Column can cause only files matching 1 value to be shown. In this scenario MediaMonkey is not splitting the Album along the sorted value.
Steps To ReproduceRequirements are having 2 Albums for the same Artist

1) View an Artist in the Art (By Album) mode (I used FMFS to get there)
2) Make sure your initial sort when opening this is Album
3) Keep sorting on Rating (but also seen with Title and Genre)
4) MediaMonkey may not show all files on the Album

Also see user steps: https://www.mediamonkey.com/forum/viewtopic.php?p=481863#p481863

Unfortunately re-trying this a second time to write the bug this no longer occurred. The Album is being split along the values sorting on (so per Rating when sorting on Rating) which didn't happen when first trying to reproduce.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98283
TagsNo tags attached.
Fixed in build

Relationships

related to 0018296 resolvedrusty Track Browser: Artwork and Summary columns are listed out of order 
related to 0018210 assignedmichal Allow users to customize which fields are displayed in the Summary column/Simplified List 
related to 0018314 feedbackrusty Unable to change View / revert to default sorts by clicking on Summary column label 

Activities

rusty

2021-10-21 01:58

administrator   ~0065365

Last edited: 2021-10-21 01:59

It's really not clear how to replicate the problem (I'm not able to). If you're able to, can you update the steps?

Also, re. your second comment about albums being split when sorted by an attribute, are you suggesting that sorts should always be secondary to Groupings? i.e. if a tracklist is grouped by album and sorted by Rating then the tracks should never be split out of an album?

lowlander

2021-10-21 20:31

developer   ~0065394

Unable to reproduce on 2510.