View Issue Details

IDProjectCategoryView StatusLast Update
0017909MediaMonkey 5Playbackpublic2022-04-08 18:07
Reporterlowlander Assigned To 
PriorityhighSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version5.0.1 
Target Version5.0.3 
Summary0017909: Animate background on playback in Album Art View in Playing node can cause high CPU/GPU usage
DescriptionIn Playing node [Album Art], if Background > Animate background on playback is enabled:
- On an AMD A8 it uses 40 - 60+% CPU usage (CPU use is 3-8% if disabled).
- On AMD Ryzen 7 2700 it runs at 20% GPU (Radeon RX580).
TagsNo tags attached.
Fixed in build

Relationships

related to 0018847 closedpetr Update Chromium to v98 

Activities

drakinite

2021-10-21 17:43

developer   ~0065382

This is a non-trivial fix as the high resource usage is caused by Chromium during the render process. The animated background causes higher resource usage in MediaMonkey than in a browser because of the highly complex document tree. I believe that the animated background is already in its own render layer, and I haven't found any other way of tricking Chromium into using fewer resources for the animation.

We can attempt to create an alternative renderer using WebGL, which will run much more efficiently, but it'll take time to create.

drakinite

2022-02-16 04:31

developer   ~0066993

It looks like the Chromium update, surprisingly, has drastically reduced GPU usage on the Now Playing background animation. Lowlander, can you test on your system to see if you have the same result?

lowlander

2022-04-08 18:07

developer   ~0067501

Resource usage is no longer an issue.