View Issue Details

IDProjectCategoryView StatusLast Update
0017865MediaMonkey 5Extensionspublic2021-05-27 00:58
Reporterpeke Assigned To 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017865: Convert VBS -> JS crashes MM5
DescriptionConvert VBS -> JS crashes MM5 on some scripts like https://www.mediamonkey.com/addons/browse/item/externaltools/

Crash LOG ID: 14D1FC2F
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=32&t=99053
TagsNo tags attached.
Fixed in build

Activities

peke

2021-05-17 00:12

developer  

bug17865.jpg (48,931 bytes)   
bug17865.jpg (48,931 bytes)   

michal

2021-05-17 11:10

developer   ~0063239

VBS->JS script removed from build 2406. It was never meant to be part of standard release, reliable VBS to JS conversion is way too complex and would not generate good code anyway due to different nature of JS scripts.

peke

2021-05-21 19:33

developer   ~0063362

Verified 2406

VBS->JS script is not distributed anymore with installation.

rusty

2021-05-21 20:05

administrator   ~0063368

Jiri, can you clarify the status of this?
1) Is the the VBS --> JS converter going to continue to be made available to help convert scripts via the addons dev site? Or has it proven not useful?
2) This issue was "resolved" by removing the converter, but is it an issue with the converter? or with MM being too finicky about the code generated by it?

michal

2021-05-22 07:07

developer   ~0063391

Last edited: 2021-05-22 07:14

View 2 revisions

rusty: the error is caused by the fact, that VBS code could be too complex to parse by simple convertor based on regular expressions, like this script. It failed during processing by this script.
Based on my experience, this convertor script is very hardly usable, nearly any VBS script contains some things, that are not or cannot be covered by this conversion. Also scripts in MM5 need mostly significantly different approach, it is mostly easier to write it from scratch and use easier principles, that JS+HTML offers, and were not possible in VBS scripts, convertor would generate very messy code anyway.

jiri

2021-05-24 08:28

administrator   ~0063409

The convertor can be quite useful for some code, mainly regarding data processing. There's generally speaking no useful conversion for UI, as the logic there is way too different.

I think it'd make sense to publish this as an Addon, with a description making it clear, that it's a tool for programmers only, which can help in VBS -> JS conversion, but by no means it can do a one-click conversion of any old MM4 addon. Jordan, could you publish it sometimes?

drakinite

2021-05-26 22:11

developer   ~0063514

Added to the addons site at https://www.mediamonkey.com/addons/browse/item/convert-vbs-to-js/

Additionally, I committed a modification that should prevent crashes when it encounters errors, and instead logs the error as a comment on the bottom of the output.

peke

2021-05-27 00:58

developer   ~0063530

Re Verified 2408 Not distributed

Also verified installation of Script from addons not to generate crash, but log it as described.